1

I need to launch google chrome in the background using service that will be using AD user.

Windows service is running node.js and i'm launching Chrome by request via Socket-io. Chrome should open selected page and once page is fully loaded, socket should close it.

The problem is that service opens Chrome and closes it right away and chrome is not even able to load requested page. Problem persists only if i run node in background using service.

Everything worked perfect before upgraded chrome from 37 to 38.

I also noticed that for each open instance of Chrome there is one instance of rundll32.exe (chrome is using it for flash). And rundll32.exe instances are persistent and looks like they are crashing chrome. i dont see any rundll32.exe when I run node and launch chrome in foreground.

Does anyone have any idea what might be wrong?

UPDATE

I launched chrome with --enable-logging --v=1 and i saw these errors. Not sure what to do with them though.

[1844:1872:1023/153655:ERROR:gpu_process_transport_factory.cc(418)] Failed to establish GPU channel.
[1844:1872:1023/153655:ERROR:child_process_launcher.cc(344)] Failed to launch child process
[1844:1872:1023/153655:ERROR:child_process_launcher.cc(344)] Failed to launch child process
[1844:1872:1023/153655:ERROR:child_process_launcher.cc(344)] Failed to launch child process
[1844:1872:1023/153655:ERROR:child_process_launcher.cc(344)] Failed to launch child process
[1844:1872:1023/153655:ERROR:child_process_launcher.cc(344)] Failed to launch child process
[1844:1872:1023/153655:ERROR:child_process_launcher.cc(344)] Failed to launch child process
[1844:1872:1023/153655:ERROR:child_process_launcher.cc(344)] Failed to launch child process
[1844:1872:1023/153655:ERROR:child_process_launcher.cc(344)] Failed to launch child process
[1844:1872:1023/153655:ERROR:child_process_launcher.cc(344)] Failed to launch child process
[1844:1872:1023/153655:ERROR:child_process_launcher.cc(344)] Failed to launch child process
[1844:1872:1023/153655:ERROR:child_process_launcher.cc(344)] Failed to launch child process
[1844:3408:1023/153656:VERBOSE1:ssl_client_socket_nss.cc(3477)] CT Verification complete: result -158 Invalid scts: 0 Verified scts: 0 scts from unknown logs: 0
[1844:3408:1023/153656:ERROR:child_process_launcher.cc(344)] Failed to launch child process
[1844:3408:1023/153701:VERBOSE1:bandwidth_metrics.h(95)] Bandwidth: 294975Kbps (avg 294975Kbps)
[1844:3408:1023/153723:VERBOSE1:ssl_client_socket_nss.cc(3477)] CT Verification complete: result -158 Invalid scts: 0 Verified scts: 0 scts from unknown logs: 0

UPDATE

Opened issue with Chronium:

https://code.google.com/p/chromium/issues/detail?id=426858&thanks=426858&ts=1414158389

  • does chrome write anything on the windows logs? – JohnKiller Oct 22 '14 at 20:49
  • @JohnKiller no windows logs. also nothing in chrome://chrashes – rinchik Oct 23 '14 at 14:06
  • 1
    Failed to establish GPU channel. seems to be graphics related. Does Chrome has a "hardware acceleration" or "graphical acceleration" setting ? Disable them. Also disable third-party plugins, especially Flash (that uses graphics acceleration by default). – user256743 Oct 25 '14 at 4:13
  • @AndréDaniel I dont see these errors anymore. Tried to disable flash plugin and (all plugins) including deleting PrepFlash dll from Chrome. Issue still persists – rinchik Oct 25 '14 at 18:33
  • @rinchik the issue still persists but at least you fixed these errors, that's a start. – user256743 Oct 25 '14 at 18:35
1
+50

We had exactly the same problem with slightly different setup. We have a TeamCity agent on a server, running protractor over node.js that opens Chrome in background with WebDriver. This stopped working a couple of days ago, and after some research we came to a similar log files as yours. I would assume, there's indeed a problem with Chrome 38 for running in background. When protractor is started from console all works properly.

A solution for us was to downgrade Chrome to 37 and to disable automatic updates. It isn't so straightforward, since Google doesn't publish older versions. You may search for "Chrome 37 download" or see at one of other computers. Chrome preserves installers at: C:\Program Files (x86)\Google\Chrome\Application\37.0.2062.124\Installer. Just pay attention is should be more than ~20MB for being offline and not online.

  • Looks like nobody else has an idea how to fix this issue without downgrading it :) Your answer was helpful though. Thank you :) I will accept it as the right one – rinchik Oct 31 '14 at 17:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.