10

My customised .tmux.conf file looks like this: tmux.conf

When I zoom inside a pane in Tmux, I have no 'Z' indication beside the pane title in the status bar. I assume it's because I customised my status bar.

Is there any special 'flag' or character I should use in my .tmux.conf in order to have the 'Z' zoom indicator back?

Thanks

1
12

You want to use the window flags option in your customization, which is #F.

Note that this is the same flag for indicating that a window is active, etc. I don't know of a way to show the zoom indicator but not show the other general window status indicators.

You can check out the Formats section in the tmux man page for the full list of options.

1
  • Seems that you're right, doesn't seem like it's possible to isolate the zoom indicator. Thanks! – Mikey S. Oct 26 '14 at 14:34
13

From tmux 2.0 onward, you can use the #{?window_zoomed_flag,ZOOMTEXT,NON-ZOOM TEXT} replacement conditional in your window-status-current-format string.

For example, I use:

#{?window_zoomed_flag,#[fg=red](,}#W#{?window_zoomed_flag,#[fg=red]),}

To surround the window name with red parenthesis when it is zoomed.

1
  • There is no window_zoomed_flag in tmux 1.9a. – ntc2 Nov 24 '15 at 0:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.