1

Just bought a new Ms Sculpt keyboard for use with my Mac. Problem: Delete/backspace keys don't work.

The weird thing is that cmd+del or cmd+bkspace both work, but the keys don't work no their own.

I've opened the keyboard viewer and absolutely nothing happens when I hit backspace or delete on their own, but both light up when you add the cmd+

Ideas welcome.

4
1

Source Microsoft Sculpt keyboard + OS X issues

I was able to use the Mac OS drivers for the MS Natural Keyboard: http://www.microsoft.com/hardware/en-us/d/natural-ergonomic-keyboard-4000

See also Microsoft Sculpt Keyboard on OS X

3

After a year of use, my backspace key stopped working today.

Tried:

  • Removing the batteries for a few minutes
  • Plugging the keyboard into another machine - still does not work
  • Checked for 'stuck' function keys - This has been the culprit before but not on this occasion
  • Finally downloaded and installed the latest drivers for the sculpt comfort keyboard (Couldn't find the ergonomic drivers.) - This upgraded the Microsoft keyboard and mouse center from 2.5.xx to 2.6.xx. Straight after upgrading the driver, no restart required, all was working fine.
0

I could solve the problem by typing the backspace-key on the numeric keypad.

The backspace-key was not working on my notbook, worked fine on another notebook (both running kubuntu) but was still not working on my own machine after switching back to it. As said, after typing the backspace on the numeric keypad the backspace-key is now working again. (I'm posting this here even if not Mac-related because the problem may be independent from a specific OS.)

4
  • Your answer would be much more useful if you edit it to explain what you mean by "stroking". Nov 7 '16 at 11:19
  • Hi, thanks (I do my best with my English): typing, not stroking
    – Will
    Nov 7 '16 at 14:25
  • I figured that was probably the case and that you most likely meant to say “type” or “press” the key – but I couldn’t be sure. Welcome to Super User! Nov 7 '16 at 15:38
  • Well, stroking the keyboard may help at releasing tension, sometimes. Thanks for welcoming.
    – Will
    Nov 8 '16 at 8:28
0

I started having this issue after 1 week. I tried installing drivers or re-connecting it, didn't help. Then I tried connecting the keyboard to my laptop (also mac) and the backspace worked there, then connected back to my Mac and it works again. Seems like some internal state could be reset by connecting to another device.

1
  • Sorry yigit, I added that link to your answer by mistake, not sure how it got approved. Feel free to remove it. Oct 19 '15 at 0:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.