0

Here's the deal as a web developer I am total rookie in the hardware stuff, but since we make more money now and tried to experiment some stuff.

I got this Raid1 (4 SAS Drives) and extra 3TB Sata drive (it has some broken windows on it).

I installed my debian on the raid1 while the SATA drive was plugged out. When I plugged it in it took advantage in boot order because the Raid is never displayed in the bios menu.

My question is how to fix the boot order, so the raid would be loaded first and after that the SATA as simple storage device ?

0

somewhere in the BIOS you could have option 'boot external RAID BIOS first' or similar. Or your RAID BIOS (if existing) might have option to force it to be the boot device. If you don't, as a workaround, you could install grub on SATA drive too:

grub-install --recheck /dev/sdX

(where /dev/sdX is your SATA drive). Then no matter which drive was first, grub would start and show you same boot menu (as /boot partition is only on one drive - your RAID)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.