3

My PC Asus Windows 7 laptop doesn't go to sleep automatically. Here's what is causing it, I guess:

powercfg -requests

DISPLAY:
None.

SYSTEM:
[DRIVER] Realtek High Definition Audio (HDAUDIO\FUNC_01&VEN_10EC&DEV_0269&SUBSYS
_10431B43&REV_1001\4&1a9e13ce&0&0001)
An audio stream is currently in use

AWAYMODE:
None.

But it's not all! I suppose this is also what prevents my ASIO from working, because ASIO Panel says that the audio driver is in use too.

These processes use my soundcard

enter image description here

RAV Processes are Realtek HD Dispatcher and HD Audio Background Process.

The problem persists even if MS GM Synth, any audio programm and even system sounds are off!

Please show me the way to investigate and to kill what is using my sound!

9
  • have you tried disabling the realtek software from starting up with your system and restarting to see if that resolves your issue? – Flyk Oct 23 '14 at 14:56
  • @Flyk , there's no such option in the manager or in windows scheduler! maybe you know how to do it? – Genera Torium Oct 23 '14 at 15:03
  • start, run, msconfig, startup tab, untick everything relating to realtek – Flyk Oct 23 '14 at 15:22
  • @Flyk Thanks, I did this, but audio stream is still in use. A year ago it was all right, but now it's not... – Genera Torium Oct 23 '14 at 15:41
  • "A year ago" is hardly a useful metric. Presumably now you've disabled everything Realtek the RAVCPL/RAVBG processes are no longer listed? – Flyk Oct 23 '14 at 15:49
4

Make sure you have the latest BIOS version and drivers.

Disable the device in Device Manager.

  • If the issue goes away, then uninstall the device from device manager and reboot. The device should automatically be reinstalled by Windows. If the problem persists, run SFC /scannow from an elevated command prompt.

Note: If the problem still continues while the device is disabled, there is either a hardware malfunction, major Windows problem or something is hijacking your system which you have not found yet.

If you still can't resolve it, here is an extensive list of additional troubleshooting items too long for me to post here. It may be worth the time to go through this as well. - How to Troubleshoot a Vista or Windows 7 Sleep Mode Problem.

As a last resort, perform a factory system recovery to return the system to its original condition (make sure you backup your data).

2
  • You resolved my problem! I just reinstalled drivers of Realtek HD. I send my blessings to You. ================= – Genera Torium Oct 24 '14 at 17:02
  • Good. Glad to hear it worked for you. – CharlieRB Oct 24 '14 at 17:11
0

For others with the same problem, I discovered another potential cause. I found that there was an IP Phone application (Zooper, in my case) that was hanging on to my audio device even when not actually in use. This was preventing the system from going to sleep and caused the "[DRIVER] Realtek High Definition Audio" device to show up under the [System] heading in the powercfg -requests result.

Closing the Zooper IP phone app cleared that request and allowed my system to go to sleep automatically.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.