4

I have a new Dell M3800 Laptop, screen resolution 3200x1800, and an external 1080p Samsung monitor.

No matter what I do, the external monitor is slightly blurry.

  • Laptop: Dell M3800 (the 3rd one that is listed at $2484)
  • Vid Card: Nvidia® Quadro® K1100M, w/ 2GB GDDR5
  • Monitor: Samsung PX2370
  • OS: Windows 7 Pro
  • Connection: HDMI. And it's not the cable - I tested with another HDMI cable, no difference.
  • Desktop Background: is at least 1800 resolution, set as "fit" not stretch.

This is a breakdown of how settings affected the two displays.

Display Mode:

  • Duplicate mode: adopts the lower resolution for both.
  • Extend mode: see below
  • Projector only: Samsung display is same as in extend mode

Regardless of settings, these issues persist for the Samsung display:

  • Some entire lines of text are blurry/shadowed while other entire lines are fairly clear. ------> running ClearType made almost no difference.
  • Display is expanded, edges go off sides (e.g. only half taskbar visible) ------> Scaling aspect ratio to 66 (both vert and horiz) brings it back into frame.

There are only 2 ways that the Samsung display changes, nothing else is alterable with any settings:

Background size: changes depending on laptop resolution if laptop is set as primary.

  • When laptop is at max resolution, Samsung background looks "zoomed in."
  • Lowering the laptop resolution to 1152 and 1080, Samsung background zooms out until normal size.

Text/object size: changes only by scaling text, regardless of primary or resolution.

Laptop display

When laptop is set as primary, changing its resolution or scaling text have the expected effects on the laptop display.

But when Samsung is set as primary:

  • If laptop is at 1800 resoluation: the laptop background image is sized like a 1080 image on a 1800 screen (a small background image framed by black a rectangle in center of black background).
  • Bringing laptop down to 1080: background image is framed normally, and everything is larger, but I lose all benefit of QHD resolution.

And even then, the Samsung monitor is still blurry.

It's overall worse than my 5 year old laptop looked on this monitor, and that laptop was using a VGA cable w/DVI converter!

What is going wrong? I've been researching for hours but can't find a workaround anywhere for this particular issue (most questions involve a higher res monitor with lower res laptop, or connections other than HDMI).

  • I have the same problem. The computer does antialiasing on the external monitor, making everything burry, and I cannot get the antialiasing deactivated. – user3767013 Oct 24 '14 at 8:50
  • while your waiting for a proper answer, a search of this type superuser.com/search?q=underscan+overscan+hdmi might get you some info. – Psycogeek Oct 24 '14 at 10:17
  • I added specific models and links to specs. – DoctorWhom Oct 24 '14 at 15:25
  • @Psycogeek thanks, I'll check those! – DoctorWhom Oct 24 '14 at 15:25
  • It sounds like it's a problem with your monitor, not what's driving it, if you're having problems via HDMI and VGA with two different laptops. – Nick2253 Oct 24 '14 at 15:30
2

External monitor issue solved!
Thanks for the advice! By compiling replies to my post on several forums, I finally found the solution.

(Now only the laptop display issue remains: I can't use its native 1800 resolution, it has to be set to 1080 when the external display is primary… see details at the end of this post.)

Solution Steps:

  1. Ensure monitor is set to PC, not AV. I rechecked my PX2370 in-monitor settings and it somehow had reset to AV mode instead of PC. Changing to PC helped clarity, though only partially. It also fixed the issue where the desktop was extending beyond the edges of the screen. Now it fits perfectly.

  2. No custom aspect ratio. After fixing step 1, I re-reviewed the scaling settings in the Intel Graphics Control Panel. At the very beginning of this disaster, in order to actually fit the desktop on my external monitor, I had set it to "custom aspect ratio" of 66. That brought the edges of the picture within the boundaries of the screen. I didn't realize that that was a scaling effect, and per advice to check scaling settings, I set it back to "Maintain display scaling."

This fully fixed the clarity issue. Finally, the external monitor is clear, crisp, and scaled correctly!


Now 1 major issue remains: I lose all the benefits of the QHD display whenever I use the 2nd monitor.

In order for me to have the external monitor be the primary, my 1800 laptop has to be set to 1080.

This is because the laptop display can't have separate settings for object/text size. In 1800, it has to be set to 150% or it's illegible. But 150% makes everything comically large on my external monitor.

Also, the 1800 resolution background is shrunken and framed in black when laptop is set to 1800 and ext monitor is primary. (My conjecture is that the system rescales it to 1080 for the primary display and then uses that on both displays?)

enter image description here enter image description here

Any idea if this can be fixed?

I'm willing to live with this for now, until I get a higher res monitor (which was the plan in the next few months).

But will this still be a problem if I get a 1440 monitor?

What about with a 4k monitor?

  • You will always have this problem unless you have completely identical (size and resolution) displays. There’s also nothing you can do about this. – Daniel B Oct 25 '14 at 12:24
  • Step 1: this is called overscan and is pervasive in TV/AV, PC mode disables overscan; 2) the laptop is 16:10 aspect ratio (16/10=1.66; 3000/1800=1.66); 1080p is 16:9 (16:9=1.7[ish]; 1920/1080 = ~1.7). If one does not scale the picture, one gets cropping or an incompletely filled frame. Honestly these are not bugs, they are features: there is a mismatched system, and the system designers decided to default to certain configuration settings in the case of mismatch.. – Yorik Feb 21 '17 at 19:51
0

I spent half a day researching and attempting fixes using others advise. This morning I spent 10 seconds on adjusting the monitor's sharpness settings and voila! No more problem. All the browser font/text looks great and is now legible.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.