In Excel when I press Page Up/Page Down it always scrolls no more than 1 page and jumps exactly to the next row that was not displayed fully (if the current row isn't taller than the window, of course). This is very useful as it prevents me from ever missing a row; for example when I want to have a quick check for something in every row I can just press Page Down repeatedly and scan the whole page or column.

However when I scroll using the mouse, things are different. It always scrolls exactly the number of rows equal to the number of lines set in Windows' vertical scrolling setting for the mouse, as seen below:

screenshot of vertical scrolling mouse options

This is annoying as it skips many rows when the current 3 rows' total height is too tall to fit in the window. It also makes scrolling speed vary greatly when the rows' heights vary too much.

Is there any way to make the mouse scroll the screen by a page per notch of the scroll button?

  • 3
    What happens if you select One screen at a time instead of The following number of lines at a time in the above Vertical Scrolling dialog? – DavidPostill Oct 24 '14 at 12:43
  • Depending on what mouse you have, vendor-provided software may allow you to define app-specific behaviors. SetPoint can do that for Logitech mice. – Iszi Oct 24 '14 at 14:17
  • @David the problem with that option is that everything else is also scrolled one page at a time. Actually I want any document to scroll the distance exactly 3 times the height of a line/row but that's not possible with Excel so I want it to scroll 1 page for Excel alone – phuclv Oct 24 '14 at 14:24

I ended up using this autohotkey script

#IfWinActive ahk_exe EXCEL.EXE
WheelUp::Send {PgUp}
WheelDown::Send {PgDn}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.