6

I am running Windows 8.1, and when I tried to use bcdedit.exe (for the first time on this install) it told me that:

'bcdedit' is not recognized as an internal or external command, operable program, or batch file.

I found this odd because:

  • My PATH variable includes C:\Windows\System32
  • bcdedit.exe is in System32
  • I'm running the command from an elevated command prompt (not through some other language)

I tried a variety of other things, including using cd to go to the folder and then putting in bcdedit.exe (instead of bcdedit). No luck. Anyone know what's going on?

2
  • This indicates your system image is corrupt this isn't a permission problem, can you run sfc?
    – Ramhound
    Oct 24, 2014 at 21:33
  • Is this a fresh installation? What's your PATHEXT variable (echo %PATHEXT%)? Could you provide your entire PATH in case there's some syntax error in there? What does where bcdedit output?
    – Bob
    Oct 24, 2014 at 23:33

3 Answers 3

10

Open an elevated command prompt.

You can use this to see if bcdedit is damaged:

sfc /VERIFYFILE=C:\windows\system32\bcdedit.exe

If the file is fine you will get an output like this:

Windows Resource Protection did not find any integrity violoations.

If the file is damaged you can try to replace from backups using:

sfc /scannow

If for any reason that fails you could always try downloading the Windows 8.1 Enterprise trial, install it in a virtual machine, and copy the bcdedit.exe from it.

8

This could also be due to running a 64-bit OS, in which case you need to access BCDEDIT from C:\Windows\Sysnative\bcdedit

3
  • 1
    Agreed, this can happen if you are running Windows x64 but your cmd program is x86 (running from \Windows\SysWOW64), then bcdedit is not available. When you use "\Widnows\sysnative" in such scenario, you are referring to the x64 system folder.
    – yms
    Sep 5, 2017 at 12:05
  • Wow, its the same error msg as Linux! "No such file or directory" when its actually a 32bit vs 64bit issue. Digging deeper, its actually the binary interpreter that is printing the msg unix.stackexchange.com/questions/166755/…
    – Kevin
    Oct 28, 2021 at 20:45
  • In Windows 10 (64-bit) there is no C:\Windows\Sysnative spoke too soon :(
    – Kevin
    Oct 28, 2021 at 21:01
0

Specifically for Windows 10, https://stackoverflow.com/questions/50824048/bcdedit-file-output-doesnt-work-but-other-commands-do

"On 64-bit windows whenever a 32-bit app attempts to access %windir%\System32 directory, the access will be redirected to %windir%\SysWOW64. This process is transparent to the application and it still thinks it is accessing %windir%\System32 directory."

%windir%\SysWOW64\bcdedit.exe does not exist, which causes the error

Not the answer you're looking for? Browse other questions tagged or ask your own question.