1

I'm trying to dual boot linux on a 2006 iMac. I have tried Arch, Ubuntu, and Fedora.

I originally created the Arch USB installation media following the instructions in the Arch Beginner's Guide. Based on these instructions, I used dd to directly write the image to the USB drive. I was unable to get the iMac to boot properly from the USB media. So later on, I tried creating an Ubuntu live USB drive using dd. This was the least successful because, as I recall, the iMac bootloader wouldn't even show me an option to try to boot from the USB drive.

Most recently I tried creating a Fedora Live USB drive using the instructions provided by Fedora. Essentially, I just did sudo dd if=correct-fedora-name.iso of=/dev/rdisk1 bs=8m && sync I originally tried with bs=1m, which also failed to properly boot.

So, with my Fedora Live USB media setup, I tried booting from the USB drive and I was at the bootloader screen, I selected the Fedora option, and after that it seemed to wait for a second before proceeding to boot into Mac OS. Nothing at all came up after I selected to boot from the USB drive, other than it booting into Mac OS as it does normally.

Using the same USB drive, I tested it on my MacBook Pro Late 2013, on which it booted fine, and I was able to use Fedora a bit on the live media.

I'm wondering why booting the Fedora media did not work on the iMac. At this point I don't care much about Arch or Ubuntu. However, the Arch beginner's guide has a section about restoring a USB drive for use after having imaged it. Something about it messing with the partition scheme. This confused me a bit, but I think it's safe to assume that it is no longer a factor, given that I have overwritten the drive completely multiple times at this point?

  • I think it's most probably the iMac itself that is the problem, if your usb-drive is bootable on a regular pc, then there is nothing wrong with it. Booting Apple devices is a back art and their EFI implementation is poorly documented. You might try blessing your usb-drive (yes, 'bless' is an actual command in osx!), but if the iMac is anything like the 2008 MacBook Air, then good luck... Burn a cd instead. – JKAbrams Nov 9 '14 at 23:53
0

I had similar issues with this on a UEFI Surface Pro by Microsoft. The main problem is that most Linux distros predominantly rely on GRUB as a bootloader. GRUB is nice but sometimes a bit quirky in terms of EFI systems. Apparently even worse for Mac users.

I can't speak for Fedora either because I predominantly use Ubuntu and Arch as my preferred Linux OS.

I did however come across a tool that is designed specifically for your case (Linux and Mac). Basically a tool for loading Live CDs onto USB drives. You'd have to compile it.

Source code is here.

Hope this works for you.

0

At this stage, it is impossible to diagnose exactly your problem. As a simple example, you do not say whether the Mac requires (or not) an EFI boot.

Installing a Linux system onto a Mac is not quite identical to doing so on a Windows pc. There is a large number of pitfalls. Online guides tacitly acknowledge this: for instance the Ubuntu wiki states:

We would encourage Mac users to download Ubuntu Desktop Edition by burning a CD.

In the same vein, the Arch Linux wiki states:

Warning: It is highly recommended that this only be attempted after a clean install of OS X. Using these methods on a pre-existing system may have undesired results.

These sentences would be difficult to understand if installing Ubuntu or Arch Linux via a USB stick on a Mac were a breeze. Obviously, there must be something flaky.

Given that you are a fellow Archer, I would suggest you try following the above-linked guide in the Arch-Linux wiki (never praised enough for its clarity and accuracy) and come back with specific problems where we can provide a focussed guidance.

0

I searched for your problem on Google and found a great website which makes you do some work arounds especially when it comes to tricking Apple into accepting the boot image:

The solution I found uses the ISO 2 USB EFI Booter for Mac (with unclear origin) to boot from the ISO image of a LiveCD, but with some small but important changes: use a FAT32 file system, place the EFI file in /efi/boot/ and rename it to boot.efi. The minimal working solution for me was:

Check out the entire directions here and I hope this works for you.

Also the specs for the mac computer the post uses is as follows (it isn't technically the same computer but it is pretty close):

The white Core duo (without the 2) 32-bit Macbook was purchased in September 2006 and used to dual boot Gentoo Linux and Mac OSX using rEFIt. The original 100Mb hard disc was failing and I bought a 500Mb drive to replace it. Since OSX hadn’t been booted for some years, I decided to install Linux only. It turned out that booting Linux from a USB flash drive / USB pen drive / USB stick (or CD for that matter) is nearly impossible without rEFIt or its modern clone, rEFInd. Google found solutions that may work for more modern Macbooks (pro), but not for this machine. In addition, the original installation CD did not recognise the 500Mb disc (but reported it was 3.0Tb) and Disk Utility (luckily) refused to do anything. Hence, I needed a USB flash drive that booted on my Macbook without rEFIt/rEFInd, and I needed to prepare it on another Linux machine.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.