I have connection to IPv6 network, as well as a VPN connection (IPv4 only). However, the two conflicts with each other: when I connect to the VPN, I cannot connect to IPv6 host, by domain name or IPv6 address.

My routing table output by netstat -r shows that IPv6 connection are routed though interface en3, not ppp0 (the VPN interface)

Destination        Gateway            Flags        Refs      Use   Netif Expire
default            link#11            UCS            14        0    ppp0

Destination        Gateway            Flags         Netif Expire
default            fe80::224:97ff:fe1 UGcI            en3
localhost          localhost          UHL             lo0
cernet.edu.cn      link#9             UC              en3

But whenever I ping a IPv6 address,

> ping6 2001:4860:4860::8888
ping6: UDP connect: No route to host

There aren't many VPN providers that natively support IPv6, so I wonder if there are any workarounds that allow me to connect to IPv4 network through VPN, and to IPv6 network normally.

  • What are you using for your VPN solution? What you are looking for here is regarded as a type of "split tunneling", and is typically disallowed by most companies - and enforced by the VPN client software - due to security concerns. It is possible that your VPN client is reconfiguring something on your system to prevent any other traffic from flowing that doesn't go through the VPN server. – ziesemer Oct 27 '14 at 2:16
  • @ziesemer: I don't care about security because I use VPN just to breach Chinese Great Firewall. I checked "Send all traffic through VPN" in the settings (it's a Mac machine). I also manually add routing table for some local networks, and successfully bypass VPN in those cases. But the same thing cannot be done with IPv6. – Siyuan Ren Oct 27 '14 at 2:36
  • You should care about security so that Great Firewall does not prevent you from using VPN! – Michael Hampton Oct 31 '14 at 1:42
  • @MichaelHampton: In that case, they will just cut all your access to the VPN network. No security options can prevent that. – Siyuan Ren Oct 31 '14 at 1:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.