0

I have a big problem - I think. The problem seems to be that my HDD is Read-Only so I can't boot and can not erase the HDD to reinstall the system.

But here is the whole story:

I bought a used MacBook Pro 13" from Mid 2009. It was used by a friend and he used it until yesterday without any problems. I bought it and he erased the system and then I configurated the system for my preferences. I booted and everything worked fine. But then this happened:

  1. I changed the System-Language in System Preferences -> Language to German and then restarted.
  2. When restarting the Apple Logo appears and a loading Bar is bottom of this. The Bar took about 3 minutes to load - and then the MacBook shut down. That's it. I tried it about 5 times - everytime the same.
  3. I googled and used CMD + V at the start to see what's happening and I saw that the problem is that the system tries to repair the "volume" - my HDD. After the third repeat the system shuts down.
  4. So I tried the following steps to solve this:

  5. CMD + R when restarting to go to DiskUtil. In this I tried to scan the HDD. It returns that it should be repaired. I clicked repair and I got the message that DiskUtils can not repair the HDD. Then I clicked on the HDD and saw that it doesnt seems to be mounted... I tried to mounted but: "Can not mount this - try to repair and try again..." - but this still doenst work. So I was going on ...

  6. CMD + S to get into the console before starting the system. There I tried this: diskutil list. This returned: "Killed 9". Not more and not less. So I googled it:

  7. I found this page: [http://superuser.com/questions/698310/getting-the-diskutil-command-to-work-in-osx-mavericks-single-user-mode` So I tried the accepted comment...]

  8. and typed this into the console: /usr/libexec/repair_packages --repair --standard-pkgs This command returned this:

    Group differs on "Library/Java", should be 0, group is 80.

    Permissions differ on "Library/Java", should be drwxr-xr-x, they are drwxrwxr-x.

    Unable to set owner & group on "Library/Java", Error 30: Read-Only file system

    Unable to set Permissions on "Library/Java". Error 30: Read-only file system

Okay - that's it. This is all information I have and I realy dont know how to solve this ... any idea ? :/

Information: The OS seems to be OSX.

  • 1
    Have you tried going into Single-User mode (CMD + S) and running fsck -fy in order to run a check on the hard-disk to make sure that it indeed is not dying on you? Most of the time you see a loading bar at boot, this means the hard-disk is failing – Mike Diglio Oct 28 '14 at 13:38
  • Yes fsck -fy I also tried and its the same like CMD + V. Its trieing to repeair 3 times and after 3 times the script stops and I can type again another command. It tells me "Incorrect number of thread records (4, 288) – TJR Oct 28 '14 at 14:02
1

I've encounter this problem way too many times. Usually it means that the hard drive is logically too messed up to be repaired. I usually hook it up to a Mac, dump the home directory, and then reformat the hard drive and copy the home directory back. A few times, it's actually been a true hardware failure, but usually, it's just logical.

I've had some corruption so bad that Mac OS X itself can't recover anything off the hard drive, and in that case, I use a Linux Distribution (in my case, OpenSUSE) to yank the data. OpenSUSE can write to HFS+ partitions as long as you disable journaling on them before hand.

I usually use this command, in the case of both Mac and Linux, to copy data off. As long as you are copying to a POSIX filesystem, it'll keep the permissions.

$ sudo rsync -av --progress /run/media/linux/Macintosh\ HD/USERNAME /run/media/linux/EXTERNALHD/USERNAME

  • At home I have a Home PC with Linux (Ubuntu) on it. So it is possible to clean up the hDD with Linux ( I know how to) and then to reuse it for my Mac ? Or when doing this the error will occure again and again and again ... so its better to buy a new HDD ? – TJR Oct 28 '14 at 14:06
  • What I would do, is load up Linux via a Live CD and run an extended SMART test on the hard drive. I find that much more reliable than relying on Mac OS X itself. As long as the hard drive is formatted for HFS+, you should be fine. – Blake Johnson Oct 30 '14 at 17:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.