0

I am developing a web app and am using self-signed SSL certificates. I'm trying to test my site on Internet Explorer 10 in a modern.ie VM (in VirtualBox). When I visit the site, https://localIPaddress:3301/, I get what is pictured at this bottom of this question.

As you can see, there is no option to continue. I've tried everything, and nothing makes it appear...

  1. Looked through all options in Internet Options and tried toggling everything I could find related to security and certificates (though it's possible I missed something).
  2. Added MinRsaPubKeyBitLength 32-bit DWORD with decimal value 512 to HKEY_LOCAL_MACHINE\Software\Microsoft\Cryptography\OID\EncodingType 0\CertDLLCreateCertificateChainEngine\Config\
  3. Added the certificate I'm using to the trusted root certificates via the Internet Options "content" tab Ran Internet Explorer as Administrator

and I've rebooted after each of these things. The "continue" link still does not show.

The strange thing is, this same app URL and certificate works in another install of Windows 7 with IE10 under Parallels.

Any ideas?

enter image description here

1

The error page's Continue link is hidden:

  1. If the certificate is revoked
  2. If the certificate is deemed insecure (e.g. contains a 512-bit RSA key)
  3. If the page is in a “pinned site” instance
  4. If group policy is set to Prevent Ignoring Certificate Errors

Most likely it's #2.

Source

a security update coming to Windows 2008, Win7, Windows Vista, Windows 2003, and Windows XP in August 2012 will treat as invalid signatures that use RSA keys that are weaker than 1024 bits.

Source

If that update wasn't applied to the Win7 you tested with in Parallels then that would be why it was allowed.

  • I tried following support.microsoft.com/kb/2661254 and running certutil -setreg chain\minRSAPubKeyBitLength 512 and certutil -setreg chain\EnableWeakSignatureFlags 2, but the problem prevails... – Chad Johnson Oct 28 '14 at 16:33
  • Ah nevermind! Running these commands didn't work, but manually creating the keys did! Thank you! – Chad Johnson Oct 28 '14 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.