2

On my Windows 8.1 machine I have 2 input methods:

English Australia - US Keyboard

English Australia - US International Keyboard

As you can see, the language is always only English Australia. Please note that in Australia the US keyboard is the default one. The only customisation I did is that I added the International layout because sometimes I need to type accented characters.

However, unfortunately, when I use Win + Spacebar to cycle through the input methods, aside from the two mentioned above, I get also English US - US keyboard:

United States

Because of that, I often select English United States by mistake (my muscle memory is used to cycle through 2 input methods, not 3) and as a result I get false positives in my word processor spelling check because I obviously use the Australian/UK spelling.

I have tried many different methods to get rid of the third input method, to no avail. Nowhere in my control panel I have English US selected as a language. The only language in Control Panel -> Languages is English Australia.

I have tried many options such as "Override for Windows display language", "Override for default input method" etc. but I only get the English US option to temporarily disappear until the next reboot.

Does anyone know how to get rid of the third option in my input method menu?

  • Control Panel - Language isn't the list of installed keyboard layouts. – Ramhound Oct 29 '14 at 16:00
  • I'm sorry maybe I wasn't clear, my problem is related to the language not to the keyboard layout - look at the picture, I just want the third item to disappear. – mastazi Oct 29 '14 at 16:03
  • Your screenshot is of keyboards not language packs. You also tagged it as keyboard-layout so of course your question is not clear. – Ramhound Oct 29 '14 at 16:33
  • Ramhound, my answer is related to a language being present in the list of keyboard layouts, as you can clearly see in the picture, even though that same language is not present in the list of languages (where I have only English Australia). For this reason I have tagged it as keyboard-layout among others. Do you have any advice about how to solve my issue? – mastazi Oct 29 '14 at 16:39
  • What happens when you go to Region and Language Settings in PC Settings (not Control Panel)? – Rsya Studios Nov 2 '14 at 7:08
1

OK finally I figured it out. I'm answering my own question because it can be useful to others. Basically I have two different input methods:

  • English (Australia) / US keyboard
  • English (Australia) / United States - International keyboard

However, if I am browsing in a website, or open e.g. a Word document, which is in English US, Windows will add a third input method to the Win + Spacebar menu:

  • English (United States) / US keyboard

I suppose the reason is that while editing an English-US document, or commenting e.g. in an English-US web forum, you might want to be able to use the spell checker in US English as well, hence that third entry in your menu.

As soon as I close said document, or I leave said website (for example I go back to Google Australia) then the third option disappears automatically. It is interesting that the same thing is not done when I visit an English-UK resource, probably because Australian English and UK English do not feature significant spelling differences between them.

PS as you can see in the comments to my question there was some degree of misunderstanding about languages vs keyboards: here we are talking about input methods where any input method is a combination of a language (which is relevant e.g. for spell checking) and keyboard (e.g. English-US, English International or Dvorak). Above I have used a slash to separate the name of the language from the name of the keyboard.

0

To prevent unwanted input methods from appearing in the task bar and being selected, the following worked for me in Windows 8.1: Control panel > Clock Language and Region > Language > Advanced Settings > Language for web contents : Tick "Don't let websites access my languages list etc."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.