I am doing an NSlookup on my OSX machine and getting more than one record. domain name pointer my-machine.domain1.domainname.com. domain name pointer nintendo\0323ds.domain1.domainname.com.

What the hell? I have set my own domain name, why the hell does the DNS server think my machine is a nintendo 3ds?

I have tried reseting the cache using:

sudo killall -HUP mDNSResponder


sudo dscacheutil -flushcache

I am running 10.9.5 maybe I am not resetting the cache correctly?

  • Have you tried flushing the cache? It may have been that before?
    – EdG
    Oct 29, 2014 at 21:34
  • @EdG maybe I am not resetting the cache correctly for 10.9.5?
    – stevebot
    Oct 29, 2014 at 21:37
  • I assume you got those commands from here?
    – EdG
    Oct 29, 2014 at 21:42
  • @EdG no different site and the order of the command were different, but still the same result.
    – stevebot
    Oct 29, 2014 at 21:44
  • Posted an answer
    – EdG
    Oct 29, 2014 at 21:45

1 Answer 1


Following on from the string of comments, give this a try and then reboot

dscacheutil -flushcache; sudo killall -HUP mDNSResponder; sudo discoveryutil udnsflushcaches
  • so discoveryutil appears to be a yosemite thing, but I did attempt the restart still with no luck.
    – stevebot
    Oct 29, 2014 at 21:51
  • That's a bit odd, I've heard that works on a security update of Mavericks! Oh well... that is weird. I'll look into it a bit more.
    – EdG
    Oct 29, 2014 at 21:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .