I have a version of zonealarm on vista32 that can't be uninstalled due to a bug in that version. I have the script to manually uninstall, but I can't take ownership on any of the files. I seem to remember doing this before, but can't now.

The owner of program files is trustedinstaller. I want to change it to administrators. So far, I haven't been able to do this. Do you know a way this can be changed? Nothing I have found works. I am logged into the administrator account.

  • Can you install a later version, then uninstall it instead? – Michael Todd Dec 15 '09 at 4:27
  • I am very stubbon, and refuse to accept that I can't delete any file I want. But I am a couple hours into this nonsense and might try that. – P a u l Dec 15 '09 at 4:35
  • That's what I ended up doing (install new.. uninstall). I want to learn more about trusted installers and what power they have over the file system. I have uber-power in that I can wipe the drive :+> – P a u l Dec 15 '09 at 8:52

Try Revo Uninstaller. This might solve your problem

|improve this answer|||||
  • I agree. Revo does a great job at removing stuff that is corrupt. – Mark Dec 15 '09 at 4:31
  • That's not required. I have full knowledge of the files to be deleted. I need to know how I can delete files. I have taken ownership of system32 as administrator, and ownership of the files, but vista is still refusing to delete the files. I need to solve the ownership problem and this has first priority now. – P a u l Dec 15 '09 at 4:37
  • It's not so much of an uninstaller as it is a deep cleaner for things you don't want. If you try it and it doesn't work, here is a resource on ownership – eqzx Dec 15 '09 at 17:00
  • If it works (haven't tried it) the programmers know how to defeat NTFS security and I'd like to know how they do it while running on windows. I could not even delete the files by dual booting another version of windows, and you know they're not locked then. I think that only the signed installer by zonelabs can delete them (theory). I could use knoppix live cd and delete that way I guess. – P a u l Dec 18 '09 at 6:41

After reading your comment on nrhine1's answer, may I suggest Lockhunter:

It will show you what is locking a file and allows to stop the service/process. Unlike other programs of its kind it will not delete the file(s) but rather move them to the Recycle Bin if you wish to restore the file(s).

alt text

alt text

Lockhunter is freeware, works with all Windows versions, 32-bit and 64-bit.

Of course you can always from an external source that doesn't give a hoot about Windows permissions, e.g. a Linux Live distro!

|improve this answer|||||
  • Zonealarm is completely shut down, no processes are active. This is a permissions problem only. I can't even delete license.txt in it's program files directory. Administrator is the owner, has full permission except for 'special permissions'. So a trick has been done during install that I want to undo. – P a u l Dec 15 '09 at 5:22

I just had the same problem trying to remove ZA from Windows 7.

Running the uninstaller from the control panel or using revo uninstaller caused nasty crashes and the forced uninstaller option in revo didnt work either, even disabling ZA startup with msconfig didn't stop it from starting up.

What worked for me was booting in safe mode where I was able to uninstall the normal way from the control panel.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.