3

From time to time i keep losing audio, sometimes pulling connectors out from motherboard sockets and back in does help, sometimes even system's restart does not until it's been done twice. Disabling audio device in audio manager doesn't help at all. Switching to another audio device does, sometimes both devices are affected.

Information about my system: PC (not laptop), Windows 8.1 x64, every update's been installed, MB: GIGABYTE GA-EP45T-UD3P Currently using Windows audio drivers, previously Realtek, no differences. The same problem is with USB audio devices, including headset and microphones, every usb port, but non another devices like for flash or exhdd'.

Software like Chrome, Skype, Steam are most of the time on, but seems none of them is behind this. I have tested all of my applications that could cause this problem, like Splash Pro, foobar2000, vlc, damn even Gimp, VMware, Rosetta stone, Notepad, and whatsoever, but the problems seems to pop up from nowhere with no good reason. I have scanned my system with Malwarebytes, Dr. Web, Kaspersky, nothing has been found. Did try Windows 7 (my previous system, everything's fine).

I can't figure it.

0
6

I can't believe you went to all the trouble of removing and replacing motherboard connectors!

To simplify things for others looking for the best solution, the easiest way is to:

Right click Taskbar > Select Task Manager > Services Tab > Right click Audiosrv > Restart.

visual 1

Or if you want to stop it happening to you again then:

Control Panel > Sound > Playback Tab > Click on Sound Device > Properties > Advanced Tab > Exclusive Mode > Untick "Allow applications to take exclusive control of this device" > OK

Visual 2

1
  • 1
    This does not work for me.
    – BramMooij
    Nov 27 '15 at 19:22
3

Found a temporary fix: Open up Windows search and search for "services.msc", find "Windows audio service" in the list, in the right pane, and restart it. This would return audio, so that you could avoid PC restart or other time-consuming tries.

I haven't found the cause, though.

1
  • Tried this, didn't work.
    – ahainen
    Jul 26 '15 at 19:42
1

Go to Device Manager, disable the audio device and enable it back again. That works like a charm for me, an instant fix, more like a workaround.

0

I had the same problem. The solution for me was to roll back the audio driver. Probably installing a new driver will have the same effect. To roll back the driver:

  • go to control panel->sound
  • right click the device you're trying to play from
  • click properties
  • (the next step will differ per device)
  • under the general tab, click properties
  • go to the driver tab and click roll back driver
0

In Windows 7, I uninstalled all of the drivers then restarted the computer. As someone indicated in one of their answers, the computer will re-install the drivers when it restarts. All sound was back after that.

1
  • To possible reviewers: At first glance it seems this answer says that some other answer works. This would qualify it as a comment at most. But it looks to me none of the existing answers explicitly advises uninstalling the drivers (the closest statement is "probably installing a new driver will have the same effect"), so in my opinion the answer adds a new approach. Nov 29 '17 at 7:30
0

In my case for some reason, I didn't have the native (Realtek) drivers installed, only AMD drivers for video card which also have HDMI support. So after installing the soundcard's original drivers, the sound started working over HDMI.

0

I have logitech headphones and I had the same problem. For anyone that may have the same problem as stated and has logitech headphones, what worked for me is to go tou control panel->hardware and sound->sound->playback devices->properties on my headphones->properties again on the general page->Driver->Uninstal device. I then unplugged and plugged my headphones and they started working again. Why does this work? Idk, I was just expirementing and it worked. I also checked the box to unistal the driver with the device, so perhaps it was a driver fault.

-1

Open device manager --> Sound,Video and Game Controller --> Realtek High Def. Audio --> Right Click --> Disable --> Enable

It worked for me (in Window 10)

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.