0

Sorry if my question is stupid, but I'm trying to connect to myself using telnet, and i'm having some issues. I'm using a windows rat(Not an illegal one), it's an exe file that listens on port 24328 and allows people to connect using telnet.

so i tried to telnet to myself using:

telnet XX.XX.XX.XX.XX(My external IP Address)

Then i tried the same thing with my local IP address, nothing works. Then i tried to connect and tell telnet the port:

telnet XX.XX.XX.XX.XX 24328

Not working as well.

I Have no idea how to connect on that port, is it even possible on windows?

Thanks.

2
  • 1
    It might help if you told us what error message(s) you are getting. – G-Man Says 'Reinstate Monica' Oct 31 '14 at 20:06
  • Note: Connecting to your external IP from inside the LAN (behind a NAT router) often/usually doesn't work due to the router not being good enough to provide, or being configured to enable, that feature. Have you confirmed the RAT is actually up and listening on that port (netstat -a)? Have you confirmed there's no firewall or AV suite blocking access to the port? To repeat what G-Man requests in his comment, what are the actual error message you get when trying to connect? – Ƭᴇcʜιᴇ007 Oct 31 '14 at 20:43
1
  1. Connecting to the external IP address often fails since the consumer grade router does not allow access to its own external IP from the internal LAN. There is nothing you can do.

  2. if you want others to access your computer from Internet, you have to configure TCP port forwarding on your router for port 24328 which Must be forwarded to the local IP of your PC.

  3. you should be able to telnet to the internal IP. Try disable windows firewall completely to see whether it helps.

0

Did you enable the Telnet Server feature on your machine?

Run --> appwiz.cpl --> Turn Windows features on or off

2
  • I think he's saying that he's using the telnet client to try to connect to some other program/service (RAT). – G-Man Says 'Reinstate Monica' Oct 31 '14 at 21:46
  • OK i get it now :) – DarkStar Nov 1 '14 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.