I'm trying to use Remote Desktop Viewer to connect to remote server. I opened Remote Desktop Viewer, switched Protocol to RDP then entered my Host and my Username and clicked Connect.

gnome-session: Password: connected to uftwfbkpsvr02:3389
gnome-session: @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
gnome-session: @           WARNING: CERTIFICATE NAME MISMATCH!           @
gnome-session: @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
gnome-session: The hostname used for this connection (XXXXX)
gnome-session: does not match the name given in the certificate:
gnome-session: XXXXX
gnome-session: A valid certificate for the wrong name should NOT be trusted!
gnome-session: Certificate details:
gnome-session: Subject: CN = XXXXX
gnome-session: Issuer: CN = XXXXX
gnome-session: Thumbprint: 53:7b:c6:f6:b9:60:65:67:44:ea:06:56:c8:63:5b:a0:a1:6c:de
gnome-session: The above X.509 certificate could not be verified, possibly because you do not have the CA certificate in your certificate store, or the certificate has expired. Please look at the documentation on how to create local certificate store for a private CA.
gnome-session: Do you trust the above certificate? (Y/N)
gnome-session: Error: Could not read answer from stdin.
gnome-session: SSL_write: Failure in SSL library (protocol error?)
gnome-session: Authentication failure, check credentials.
gnome-session: If credentials are valid, the NTLMSSP implementation may be to blame.

I'm using:

[alexus@wcmisdlin02 Desktop]$ cat /etc/redhat-release 
CentOS Linux release 7.0.1406 (Core) 
[alexus@wcmisdlin02 Desktop]$ 

What am I missing? What am I doing wrong?


I Google for this issue and found following that looks like matching what I'm describing:

I CAN also use another tool to do RDP session, but I was wondering if someone has another solution for Remote Desktop Viewer itself.

  • What version of the RDP is the host using? Which versions does the client support? – Ƭᴇcʜιᴇ007 Oct 31 '14 at 20:25
  • @Ƭᴇcʜιᴇ007 I'm using vinagre-3.8.2-4.el7.x86_64, which is latest available version for CentOS 7. – alexus Oct 31 '14 at 20:28
  • That's not what I meant by the RDP version; there are different versions of the Remote Desktop Protocol. Also, it looks like you may have hit this bug, have you investigated that yet? A simple Google for your SSL-wirte error turned up that link, plus lots of other ideas/suggestions. What have you tried already? – Ƭᴇcʜιᴇ007 Oct 31 '14 at 20:30
  • @Ƭᴇcʜιᴇ007 I Google it too) AND I found some info about this bug as well even on redhat's site, however none of that address Remote Desktop Viewer itself, and as a workaround I was able to connect using xfreerdp and/or other clients as well, but that's not why I'm here) – alexus Oct 31 '14 at 20:41
  • So you're suggesting that the bug I linked, which is linked as the cause of this Redhat bug report is not the same problem you have? Even though they are talking about the same program, and showing the exact same results? Partly what I'm driving at is that we can't read your mind, so we have no idea what research you've done, or what repairs you've already attempted. Please edit your question to include that kind of information, so we don't spend time suggesting things you've already seen/tried. ;) – Ƭᴇcʜιᴇ007 Oct 31 '14 at 20:49

Look in the file $home/.freerdp/known_hosts.

Delete the server you're having issues with and try reconnecting.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.