6

I'm running OSX Yosemite. I have Virtualbox 4.3, and I use a Windows7 virtual machine for IE development.

I am having an issue where every time the machine boots to safe mode it reboots to normal mode. I have tried with msconfig but that just got me into a boot loop.

I've seen some talk about this, but I can't seem to find a solution.

Does anyone know how I can get into safe mode?

Thanks!

7

You could try to start the VM. While booting reset it and normally Windows 7 will asks you if you want to boot into the safemode or just start windows. Or you can try to catch the keyboard at the very beginning of the boot process (while the VM is in the virtual BIOS) an keep hitting F8, than you should also get the option to start into safe mode.

EDIT:

It has nothing to do with virtual box. The Windows 7 Enterprise Evaluation has a bug so the safe mode doesn't work. One solution could be the "safe mode with networking". (Source: https://social.technet.microsoft.com/Forums/windows/en-US/ef0e41cb-955b-4a29-9318-2c56a198d746/windows-7-enterprise-safe-mode-problems?forum=w7itproperf )

  • 1
    That's what ive been trying. It boots into safe mode, but near the end of the process it automatically reboots into normal mode. If I do it via msconfig it gets caught in a loop of this. – jacobcc Nov 2 '14 at 0:21
  • Which Windows 7 version do you use? Windows 7 Enterprise Evaluation? – bejonwe Nov 2 '14 at 1:02
  • yeah, Windows 7 Enterprise. 90 day Evaluation – jacobcc Nov 2 '14 at 1:52
  • 2
    OK, than it has nothing to do with virtual box. The Windows 7 Evaluation has a bug so the safe mode doesn't work. One way you can try is to choose "safe mode with networking". (Source: social.technet.microsoft.com/Forums/windows/en-US/… ) – bejonwe Nov 2 '14 at 1:55
  • "Safe mode with networking" results in the same issue - the boot process never completes. – Nathan Osman Jun 23 '17 at 2:05
6

I have similar setup and forced safe mode with msconfig that resulted in the endless boot loop. I tried all other safe modes with no luck. Even if I selected the normal mode in F8 menu, the system tried to boot in the safe mode and failed. The solution in my case was to select the repair mode in F8 menu, enter login/password (default IEUser / Passw0rd!), select the command prompt option in the recovery menu and use these commands

bcdedit
bcdedit /deletevalue {default} safeboot

to reset msconfig settings ({default} is identifier of boot loader from the output of the first bcdedit command). This way the system became bootable.

-1

An easy way is to first run msconfig from the Start Menu. Goto the "Boot" tab and choose "Safe Boot". Once you close msconfig it will ask you to restart your computer at which time it will boot into safe mode.

With this approach you don't have to worry about trying to press some keyboard button at the right time at boot or forcing safe mode after a hard shutdown, etc.

Also, once you are in Safe Mode, simply run msconfig again to turn off "Safe Boot" in order to get back to Normal.

enter image description here

  • This way isn't work for me, and now my virtual machine always tries to start in safe boot, but fails. – Macabeus Dec 15 '18 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.