I have a small network with a modem, a WRT54GL router and my laptop. When I connect my laptop directly to the modem I can access the web interface of the modem by navigating to (this cannot be changed). When I connect my router ( to the modem and then connect my laptop to the router I can not access the modem any longer.

I have confirmed that I do not have an IP conflict. I'm able to get on the web and access the DD WRT UI of my router but I can't access the modem any longer.

Here is the WAN Connection info from the router:

Connection Type: Automatic Configuration - DHCP 
IP Address: xxx.xx.xxx.xx 
Subnet Mask: 
DNS: 1148.78.249.200 
DNS: 2148.78.249.201 

And here is my Network Adapter info (ipconfig):

DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . :
Subnet Mask . . . . . . . . . . . :
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . :
DNS Servers . . . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Enabled

I see that the subnet mask is different and I suspect that essentially means I have two networks: My modem-router network and my router-laptop network, however this is just a guess and I'm reluctant to change things I don't understand.

If the subnet masks are the reason I can't get to the modem from the router is the solution to update the DHCP configuration on the router to use the same subnet mask as the modem is handing down to the router?

3 Answers 3


The reason you can't reach the modem, is because the IP address of the modem is on the same network as your LAN, but isn't connected to the LAN (its connected to the WAN). The easy fix, if you can't change your modem IP, is to change your LAN IP range. Use something like instead of Basically change your router IP to and your DHCP server to serve IPs in the 192.168.0.X range.

Detailed Explaination

Right now you actually have 3 different networks: Network Diagram

As you can see in the image, the LAN and modem are on the same network, but separated by the router. The reason this is a problem is because when you send a packet to from your computer on the LAN, the netmask ( says that any IP from should be on the LAN, so it performs an ARP query to find the MAC address of the machine with that address, but no machine on the network has that address, so it fails.

However, if they are different networks, they packet will always get sent to the default gateway(the router) which will then send it out the WAN port since it not destined for any of the devices on the LAN.

  • Excellent description and I appreciate the diagram! I made the changes waited a few minutes why things were released/renewed and now everything works. Thanks again!
    – Steve K
    Nov 2, 2014 at 6:44

The following seems to work with my cable modem (Arris SB6141) and router (Linksys EA8500).

Cable modem has NON-CONFIGURABLE fixed LAN address of WAN side of cable modem is DHCP-set by ISP. (Don't know it's mask.) ISP is Comcast/Xfinity (copper)

  1. My setup:

internet->cable-modem->router-> my-lan (192.168.1.xxx) my-Gateway (

  1. Cable modem internet-facing interface is presently DHCP assigned by comcast (WAN interface) as xxx.xxx.xxx.yyy where xxx is the domain portion of IPV4 address assigned by my ISP and yyy is my particular address on the internet (WAN) side of the modem.

  2. Added a static route: Name Destination Subnet-Mask Gateway Interface Cable Modem xxx.xxx.xxx.0 internet (WAN)

Note: Not sure why the 0 in the WAN interface works or if it's a security risk. Haven't forced a DHCP renew on the WAN side to test if it continues to work.


I had the same problem with a Linksys WRT 1900 ACS router and Arris SBV3202 cable modem. I tried the solution recommended in the preceding comment, using the first three of the 4 sets of digits of the ip4 assigned by comcast (found by going to whatismyipaddress.com) and a 0 in the fourth field as recommended, and it did not work. However, when I entered the entire comcast-assigned DHCP address, including the last set of digits instead of 0 (i.e. the entire xxx.xxx.xxx.yyy described in the previous note), it worked perfectly as soon as I entered in the browser.

I think that each time you disconnect the modem and reconnect, you will have to change the target address in the fixed route in the router to match the new ip4 address assigned by comcast when the modem restarts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.