7

Note: I would rather comment David's answer in: Unable to connect to wireless after upgrading to Windows 8.1 from 8, but I don't have the required 50 reps to do so.

I recently upgraded to Windows 8.1 and today since I had forgotten my router access password I reset it. Upon resetting the router my system was unable to connect to the wireless network (it just didn't ask any password.. ) so I followed the steps described in the above link and I can now connect through the wifi.

But, the network is automatically renamed to "--networkname-- 2" upon first connecting to the network. Other devices still see and use only the network SSID without the "2" added. If I re-delete the profile and reconnect the same happens again.

I'm using an Asus convertible tablet (T-100) with a Broadcom adapter.

NOTE: after the automatic renaming both profiles (with and without "2") exist, but the name shown in Windows' Network and Sharing Center is the one without the "2", the name shown in the right-side hidden blue bar is the one with the "2".

What's going on with Windows 8.1 on my device?

  • There is nothing wrong with your 8.1 device, all it is saying is that it has a previous config from a network with the same name as the network with the 2. The only thing causing this is the fact it has a previous config -TD – td512 Apr 15 '15 at 15:59
  • @TD.512 the fact is that it is not "letting go" of the previous config when told to delete it; anyway I had to change the SSID for other reasons and I can't tinker around with it anymore – maja Apr 18 '15 at 9:17
1

Go to Settings (Charms Bar) -> Change PC settings -> Network -> Manage Known Networks.

Select your <networkname> and press forget. Reconnect your network again and the suffix 2 will be removed.

0

To rename a Wireless Network Connection:

  1. Goto Control Panel / Network Connections

  2. Select the Wireless Network Connection

  3. Right Click

  4. Select Rename

enter image description here

  • It shows without the number "2" in that menu, it shows with the number "2" in the hidden blue system bar on the right (and in the netsh profile both are present, the one with the "2" created when I first connect to the internet using the original profile) – maja Nov 2 '14 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.