2

On the latest Tb 31.2.0, with HTML composing disabled, and no signature, I often experience this: I open a new/blank Compose window, or hit reply, and start typing in the main area, only to find that it appears Tb is not responding. 5-20 seconds later, every keypress or mouse click I had performed suddenly takes effect. After that, it may run smoothly the rest of the composition, or it may happen again once or twice, for an average 1-2 paragraph e-mail. I've experienced this on Windows Server 2003 and Linux Mint 17, both 32-bit editions.

I have no calendar plugins or anything composition-related installed that I can tell (only DivX Web Player, Google Talk, IcedTea, QuickTime, Shockwave Flash, VLC, WMP on Linux and there's the Messaging Menu and Unity Launcher integration 1.3.1 extension but no others; on Windows, no extensions whatsoever, and Foxit, MS DRM, Shockwave, Silverlight, MS WPF--all the defaults on both platforms). On Mint I'm accessing Gmail via IMAP and have a gigantic inbox, on Windows a private server via POP and my inbox has under a dozen e-mails in it (the rest are in archived folders according to year.) I have Global Search and Indexer disabled. On the Windows box, I have the OS-wide file indexing service disabled.

I have not tried safe mode yet, but I'm curious how video player plugins or a popup integration extension could interfere so detrimentally with a text composition window. I'm tempted to switch to a CLI for e-mail. The basics shouldn't be so painful...

UPDATE: In safe mode on Linux just now, I was manually disabling every plugin permanently, when I had a similar thing happen in the add-ons window, a 5s delay before the dropdown menu for "always activate/never activate" responded to my initial click.

2
  • Exactly the same problem here with a Gmail imap mailbox (not that big actually), under Debian jessy (3.16-3-amd64) and Icedove 31.2.0, with addons Adblock Plus,Enigmail,Iceowl and Provider for google calendar. Was already slow with Gmail mailbox anyway, but it seems that since the last version it really freezes for many seconds, and very often... – yago Nov 11 '14 at 17:24
  • I have, however, still experienced it. – Kev Nov 25 '14 at 15:55
0

I think I found the cause. I ran Tb from a Terminal one day and watched it. Just when warping happened, there appeared two new entries like this in the Terminal:

1423554445542   addons.update-checker   WARN    HTTP Request failed for an unknown reason

...which would explain the same warping happening on the add-ons screen, sort of (it makes more sense there than in a compose window.)

I used the config editor in Tb to set extensions.update.enabled to false. Of course, there are risks associated with this, but it might help narrow it down. I haven't had it happen since then, but we'll see.

UPDATE: I have had it (the warping, not the log) happen again, but with a much shorter wait, ~1.5s.

UPDATE 2: Still having it happen, Tb 31.7.0.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.