0

On my Windows 8.1 system, I have a folder called "D:\Benutzer\Alle\Musik" (I'm german, this is like Users/All/Music) which was linked to the Music library folder in windows. I decided to add my music archive to OneDrive so that I could listen to my music from other devices. So I changed the location of the music folder to "D:\SkyDrive\Music" (simplified that a bit for your convinience but you get the point, it's not relevant). Windows then asked me, if I really want to move one System folder to the other, and of course I confirmed because this was what I wanted to do.

Surprisingly, Windows started to copy the files (not to move them). Once the copy process was completed, my music is successfully located in the synchronized OneDrive folder, but I lost complete control over the previous music directory (which is, I believe, still taking up the space).

When I try to visit the folder in Explorer, it says: Means just access denied and the header sais, path is not available

Access denied and the header says, path is not available

When I attempt to go to the Security settings (with "advanced" settings = "Erweitert"): Folder security tab Advanced security details

These are the folder security tab and the advanced security details. Basically, all show the message that "You don't have permission to display the security properties of this object" or "The current owner cannot be displayed", even if unlocked by UAC (also, disabled UAC temporarily without success) the message is the same

So I tried to go to "next level" and working with the command line in administrator mode. Here are the results for icacls:

D:\Benutzer\Alle>icacls Musik /T /RESET
Musik: Zugriff verweigert
0 Dateien erfolgreich verarbeitet, bei 1 Dateien ist ein Verarbeitungsfehler aufgetreten.

Access denied; 0 successful, 1 error occured

Attempts with takeown:

D:\Benutzer\Alle>takeown /f Musik
Fehler: Zugriff verweigert

Error: Access denied

Attempts to 'dir', del, rmdir etc.: See above.

I'd like to get access to this folder again to be able to double-check if everything was copied etc. but if this doesn't work, I'd at least need to delete the folder and it's contents. What are your suggestions?

  • What happens if you do a reboot? – Rsya Studios Nov 3 '14 at 11:16
  • @RsyaStudios Forgot to mention, I rebooted multiple times since then w/o success. But I get the idea, maybe try some of the "move/del on reboot" utils next... But I'm trying the on-board/standard tools first – thomasjaworski.com Nov 3 '14 at 11:27
  • With elevated privileges, try icacls "D:\Benutzer\Alle\Musik" /grant User_name:(OI)(CI)F. F = Full Control; (CI) = Container Inherit, flag indicating that subordinate containers will inherit the ACE; (OI) = Object Inherit, flag indicating that subordinate files will inherit the ACE – JosefZ Nov 3 '14 at 12:09
  • @JosefZ thanks for your suggestion, results in same error message when tried to /RESET. (using Console in Administrator mode) – thomasjaworski.com Nov 3 '14 at 12:28
  • @thomasjaworski.com Did you try to work on this folder in Safe Mode? – JosefZ Nov 3 '14 at 14:15
0

I left this problem for a few days, and when I attempted to take care of it again, it was gone. I was able to access the folder and it was empty. I could delete it easily. It wasn't only a single reboot, i had multiple reboots in the meantime which didn't solve the problem. I'm not sure what actually did. At least what I know is that a windows update was applied in the meantime. Thanks for your help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.