2

Synopsis: I moved, the PC (without the HD) got totalled, I ordered a new machine with the exact same hardware. Meanwhile, I tried to copy some files to another machine by plugging in the HD externally, but all files in the /User/Documents/ folder are protected/encrypted (I didn't encrypt them). I fiddled around with the rights and ownership of those files but to no avail, and I was later unable to revert the changes I made. So I guess I should probably not have done that. Anyway, the new machine eventually arrived, I plugged in the HD, and after loading AtiPcie.sys I was greeted by a BSOD that immediately forced a reboot so I don't know what the error message actually said, but I suspect an IRQL_NOT_LESS_OR_EQUAL because that one has followed me my entire life.

Here's a list of things I did in my vain attempts to solve the problem:

  • Safe mode
    No effect at all, except that the (probably same) BSOD occurs after loading CLASSPNP.sys instead.

  • Various hardware checks including chkdsk
    No problems found. To be certain, I plugged in another HD and installed Win2k on it. It boots just fine.

  • Recovery console: bootrec /rebuildbcd
    The operation "completed successfully" (after renaming the old BCD file) but had no effect.

  • Recovery console: bootrec /fixmbr, bootrec /fixboot, bootsect /nt60 all
    Same as above, except now the list of drivers loaded during startup is replaced by a Windows logo and a loading bar. I preferred the list.

  • StartRep.exe
    After a while, this gave me an error with the following problem signature (from memory, I didn't think I would be unable to replicate it later):

    Problem Event Name: StartupRepairOffline
    Problem Signature 01: 6.1.7600.16385
    Problem Signature 02: 6.1.7600.16385
    Problem Signature 03: unknown
    Problem Signature 04: (sth long, don't remember)
    Problem Signature 05: ExternalMedia
    Problem Signature 06: 13 (I think)
    Problem Signature 07: BadDriver
    OS Version: 6.1.7601.2.1.0.256.1 (or sth like this)
    Locale ID: 1033
    

    The only external devices at that point apart from the monitor were a USB keyboard and a USB mouse. Ever since then, StartRep.exe immediately completes with no problems found. Also, BSOD as usual.

  • Removed AtiPcie.sys and atikmdag.sys
    Didn't seem to do anything.

  • Changed the RAID mode of the HD (IDE/RAID/AHCI)
    Didn't seem to do anything.

I'm reluctant to do an "in-place upgrade" a.k.a. reinstallation since it seems this might permanently make the user documents inaccessible. According to my research, the encryption is linked to the OS installation and would get overwritten if I reinstalled Windows. (Side note: I did copy the certificate files to another PC but was unable to do anything with them; see here for more details.)

So, any suggestions how I might get that machine running again, preferably without losing my protected documents?

Edit: I finally figured out how to display the BSOD message:

STOP: 0x0000007B (0xFFFFF880009A97E8,0xFFFFFFFFC0000034,0x0000000000000000,0x0000000000000000)

A Google search returned some relevant results but no applicable solutions. Repairing isn't an option, I already rewrote the BCD, and changing the RAID mode had no effect.

  • You won't be able to do an in-place upgrade if you cannot log into Windows without getting a BSOD so that's not even an option. Likewise if the files are encrypted then taking ownership isn't an option. – Ramhound Nov 3 '14 at 16:00
  • It seems to me that the core issue is the changed IDs of the hardware. Surely there has to be some proper procedure here, or am I seriously supposed to reinstall Windows whenever I swap the mainboard? I can't recall ever encountering this problem with old Windows versions like NT 4.0. – And G Nov 3 '14 at 18:13
  • There is a process. Sysprep allows you to migrate an installation on a HDD or create an image to apply to multiple HDDs when booted allows Windows to reconfigure itself for the new hardware. There are also programs that will allow you to create an image of the hdd then restore on dissimilar hardware. What was possible in NT 4.0 isn't relevant 2 decades later. Of course it sounds like, while trying different things, even if you were to create that image then restore it you have actually deleted files Windows needs. – Ramhound Nov 3 '14 at 18:16
  • But that's something you'd need to do in advance. So basically, if you have a modern Windows (NT 6.0 and above?) and your mainboard blows up for whatever reason, then your OS is terminally screwed, is that correct? Or would you be alright with e.g. Windows 7 that comes with an actual repair function? – And G Nov 3 '14 at 18:35
  • You could use Acronis, create an image, then restore that image using a version that supports restoring the image to new hardware. Does not require access to a working Windows installation. – Ramhound Nov 14 '14 at 15:41
2

Not sure why my question was downvoted or why I never seem to get useful answers on Superuser, but in any case I finally got it to work by using the recovery console to reinstall the mainboard drivers from the DVD with DISM. The particular command that did it for me is DISM /image:C:\ /add-driver /driver:G:\ /recurse with C being my OS partition and G the DVD drive. I had to reinstall the graphics chip drivers, but other than that everything is just the way I left it.

So yeah, easy solution and none of the things I tried were even necessary.

  • 1
    This worked for me. Life saver! – Joel Harris Dec 21 '15 at 16:25
  • I had this with a HyperV VM that I had to restore in VMware which resulted in 0x7B BSOD aswell. Simply installing the drivers wasn't enough. Afterwards I changed the SCSI Controller to Paravirtual. Since this was an SBS2011 Active Directory complained that an attached device wasn't working. I booted in Active Directory Recover Mode and installed the rest of the necessary drivers. – lsmooth Apr 12 '19 at 9:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.