Using OSX Yosemite 10.10. Login screen defaults to Dvorak. Also, input menu at upper right of login screen defaults to Dvorak and must use pull-down menu to locate US keyboard every time at login. I have no need for Dvorak at all anymore. How can I get my mac to default to US for login?

Superuser Lri posted this string in response to a similar question: Run sudo rm /var/db/.AppleSetupDone; sudo /System/Library/CoreServices/Setup\ Assistant.app/Contents/MacOS/Setup\ Assistant.
I did a cut-and-paste and hit Enter, but Terminal responded that it did not recognize the command and warned me that an improper sudo command could seriously wreck my machine. Can anyone tell me what I did wrong, or give a step-by-step for a code-illiterate mac owner?

2 Answers 2


Also, you can copy the plist file to your desktop and edit by Xcode than overwrite back.

sudo cp /Library/Preferences/com.apple.HIToolbox.plist Desktop/
sudo chmod 0777 Desktop/com.apple.HIToolbox.plist
sudo open Desktop/com.apple.HIToolbox.plist
sudo mv Desktop/com.apple.HIToolbox.plist /Library/Preferences/
sudo chmod 0644 /Library/Preferences/com.apple.HIToolbox.plist
sudo chown root:wheel /Library/Preferences/com.apple.HIToolbox.plist
  • +1 for mentioning chown root:wheel which is required.
    – risyasin
    Jan 26, 2015 at 19:46

I had this problem a while back as well. Here's what I did:

1. Login to your account like normal
2. Open Terminal
3. sudo cp ~/Library/Preferences/com.apple.HIToolbox.plist /Library/Preferences/
4. sudo chmod 644 /Library/Preferences/com.apple.HIToolbox.plist
5. reboot, and you SHOULD be all set!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.