8

I'm using a Dell Latitude laptop with two external displays. When I make a connection in Remote Desktop (Windows 7) and maximize the window it only resizes to the max resolution of my built-in display (1360 x 768), not the external monitors (1680 x 1050). I've seen a lot of answers which say to use Ctrl + Alt + Break, but that doesn't work for me -- it's the same size screen with a big black border around it. Is there any way to fix this? Like if I manually edit an .rdp file?

  • 2
    An rdp session will by default take of the size of the main screen the session was started on. That session will not change size simply moving it to a different resolution of monitor. This bugged me a couple years ago and i have been using RD Tabs since. With that tool i can move a session to a new screen and disconnect/ reconnect for it to assume the resolution of the current screen. – Matt Nov 3 '14 at 21:11
  • RDP 8.1 supports dynamic resolution update (if you connect, disconnect monitors, move full screen windows around): blogs.msdn.com/b/rds/archive/2013/12/16/… . – cdavid Nov 3 '14 at 21:55
9

The below procedure worked for me on Windows 7:

  1. Open "run" prompt
  2. type mstsc.exe
  3. click on "Options" option in the bottom-left corner of the "Remote Desktop Connection" popup
  4. click on "Display" tab
  5. Change "Display Configuration" to "Full Screen" by dragging the slider to extreme right.
0

When you are using a lot of different RDP destinations you may save one generic RDP file and then open it with the texteditor. Then add at the end of the textdocument

smart sizing:i:1
span monitor:i:1

And as well you may try to change the following attributes to your ressolution

desktopwidth:i:1366
desktopheight:i:768

This makes the session smart sizable. For me its pretty nice. There are a lot of different setting you can change see http://ls.df.vc/files/rdp/RDP_file_settings.htm

As well you may look for a 3rd party RDP session manager.

0
  1. Go to your run prompt and type mstsc to pull up your RDP client. (If you are using a shortcut you can right click and select properties to get to the correct place as well).

  2. Click 'Advanced Options' on the bottom.

  3. Modify the 'Display Resolution' option in order to get the option to set it on both screens, set full screen or specific resolutions, etc. This should fix your problems :)

Make sure to save the connection again or manually launch it from the connection tab to ensure it saves the settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.