6

I have a 7-Zip file on my (Windows 7) desktop with the extension .7z.

I was mistakenly led to believe that Windows 7 could handle it like it handles its own "Compressed (zipped) folders".

So I did the whole "Open with..." thing and got the extension associated with "explorer.exe".

Then when I double-clicked on the file I just got the wait/hourglass cursor flashing like crazy. But that's not the problem... the problem is that I now want to un-associate .7z with explorer.exe, or at least associate it with something else, but the "Always use the selected program to open this kind of file" checkbox is disabled.

Apart from the specifics of the mess I created for myself, the general question is, if the "Always use the selected program to open this kind of file" checkbox is disabled, how does one enable it?

3

I found the answer at this now-closed (as off topic) Stack Overflow question: https://stackoverflow.com/q/2543254/253586

  1. Launch regedit.exe
  2. Navigate to the following subkey: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts
  3. Scroll down and find the file extension you are having problems with (for me it was .7z)
  4. Expand it to view its sub keys
  5. Find a sub key called "UserChoice" and delete it.
|improve this answer|||||
1

Sometimes UserChoice isn't available using regedit.exe. According to an answer elsewhere, the following instructions will work for a given file extension:

  1. Open the Start menu.
  2. Type: default programs
  3. Select Default Programs.
  4. Click Associate a file type or protocol with a program.
  5. Select the first line in the list that appears.
  6. Scroll down or type the filename extension (e.g., .svg -- important to include the leading dot)
  7. Click Change program button
  8. Click the program you'd like to associate with that extension.
  9. Click OK.
  10. Click Close.

The desired program is now associated with the given file type.

Note: When choosing the program, notice that the option (Always use the selected program...) is still greyed out but, in this sequence of steps, the option is checked.

|improve this answer|||||
0

Without wishing to denigrate Jeff Roe's answer, there is a simpler solution, which does not require the use of regedit:-

  • Find any .7z file.
  • Right-click and select Properties.
  • On the General tab there is a line which has "Opens with" and the name of the associated program.
  • Click on the adjacent Change... button.
  • If you don't see 7-Zip in the list of recommended programs, click on the down chevron on the Other Programs line.
  • If you still don't see 7-Zip, press the Browse... button and navigate to where it's installed.
  • Make sure that Always use the selected program to open this kind of file is checked and press OK on both windows.

You will not be able to clear an assignment this way, only to change it.

|improve this answer|||||
  • 2
    This doesn't work when the "Always use the selected program to open this kind of file" checkbox is disabled. – David Robison Mar 7 '16 at 21:23
  • @DavidRobison - I've not encountered that problem, but I always use an administrator account. Maybe it's a problem with limited accounts, but I wouldn't expect them to be able to make changes with regedit. – AFH Mar 7 '16 at 23:41
  • It's a bit buried in the original problem description, but that's the specific problem the original user had (and me, which is how I found this topic). – David Robison Mar 8 '16 at 3:10
  • @DavidRobison - OK. I missed it when I read the question - thanks for your comments. I'll leave the answer in case it is useful to someone who doesn't have this problem - I used to do registry manipulation before I discovered the GUI method, and as I said I still need to do it if I want to remove an association without assigning another. – AFH Mar 8 '16 at 14:21
0

I'm on Windows 7 too, and I found the check-box is grayed out when I right-click the file as well.
If the file is on your desktop, you can still have it there, but you need to access it through the Explorer. (Windows +E opens Explorer.)
The Default Tool Bar menu is; "Organize, System Properties, Uninstall or change a program, Map network drive, Open Control Panel".

  1. Navigate the folder(s) to where your file is located.
  2. When you select a file type, the toolbar menu changes from the default toolbar to one of a few different configurations.

The most common configs are...
[.bmp] Organize - Preview - Share With - Slide show - Print - Burn - New Folder
[.mp3] Organize - Play - Play All - Share With - Burn - New Folder
[.txt] Organize - Open - Share With - Burn - New Folder

  1. Notice the 2nd menu item is "Preview, Play, or Open".
  2. Use the pull-down menu from whichever the 2nd item is, and select, "CHOOSE DEFAULT PROGRAM...".
  3. The "Always use the selected Program..." checkbox is now available.
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.