I replaced my working 350W power supply with a new 500W power supply. My computer would not boot with the new power supply. It would turn on for a few seconds and then turn off. I then tested the new 500W PS in a different computer and it runs just fine. I used a Kill-a-Watt meter and found that my computer is only using 87W of power.

Is it possible that the under-voltage or under-current protection in the PSU is causing it to shut off because my computer is not drawing enough power? I've also heard that it is very inefficient if you are drawing less than 20% of your PSU max power. In my case 87W out of 500W is only drawing 17% of max power.

Additional information:

This is a home-built computer with Gigabyte P55 based motherboard. The board uses the 24+4 pin ATX connector and a 8 pin connector for the CPU. It works just fine with the 350W which only has a 24 pin ATX connector and 4 pin CPU connector. With the newer 500W PSU I tried various combinations of 24/24+4 for the ATX connector and 4/8 pin connector for the CPU.

Other differences between the PSUs are that the old one had a 115V/230V selection switch and the new PSU auto adjusts. Also the new PSU is modular and I tried with and without any of the SATA power connectors connected.

I even tried clearing the CMOS, took out the battery and waited 15 minutes.


Although a too-large power supply will have an extra margin of safety as far as not over-loading, a larger unit is often less efficient at lower loads (under 20% of its total capability) and therefore will waste more electricity than a more appropriately sized unit. Additionally, computer power supplies generally do not function properly if they are too lightly loaded. Under no-load conditions they may shut down or malfunction.

  • 2
    My only question is why is your computer only drawing 87W, perhaps this is where your problem lies. – user119173 Feb 19 '12 at 21:53
  • Power supplies are like hard drives; They can never be too big. – MDMoore313 Jun 12 '13 at 0:53
  • CAUTION: This question is out of date and no longer relevant to modern computers and modern power supplies. – David Schwartz Aug 19 '15 at 23:17

It's theoretically possible. Switching power supplies (like a PC PSU) all have a minimum load requirement, typically on the +5V rail. Perhaps there was a device you forgot to plug in on the +5V/+12V rail?

| improve this answer | |
  • 4
    OK, +1 because it is possible. That said, it's horribly unlikely. I've run VERY low current devices off of PC power supplies on a bench and never hit the minimum load requirement on any of them. :-) – Brian Knoblauch Dec 15 '09 at 20:54

No such thing as a "too big" power supply. It's like a big engine...It needs to be big enough to pull the load, and if it's bigger than that, no big deal. It's not efficient, but it's not going to cause functional problems.

What I would check is to make sure you have the right kind of power supply. Are you sure the power connectors are the same between your motherboard and power supply. Lot of name brand PC manufacturers change the pin outs on their motherboards, so you have to buy a power supply from them.

Also, check and make sure that you've plugged in ALL the plugs. If the motherboard expects something, and it's not there, it'll automatically shut itself down.

| improve this answer | |

It seems much more likely it was simply installed wrong.

| improve this answer | |

While there is no such thing as too big of a power supply, too big one of one can run inefficiently. All power supplies have a sweet spot, at which they provide the best conversion of power. Each power supply has it at a sightly different spot. Typically this spot is around 40 - 70% use. But that can be a large range. So if you are worried about efficiency look this up before hand.

As long has the power supply has the correct cables for your motherboard, you should be fine. Over the last few years there have been some extra cables added to provide extra power to the CPU and/or Video cards. Some video cards even require a cable be plugged into the back of them.

More the likely you've got a cabled plugged into the wrong spot, or you are missing one.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.