0

I'm trying to forward a port to access my computer outside of local network.

I've set up remote desktop to listen on port 3391.

When I try locally, I can connect.

When I try from remote machines, I can not. Not even telnet.

When I disable windows firewall on the machine I'm trying to connect to, I can telnet. But still can not connect with remote desktop.

What else can I try here?

When I connect through local address it warns me about bad certificate. Port forwarding seems to work because I tried turning off RDP and setting apache to use its port. I was able to load local pages remotely.

I've also checked remote desktop in the list of allowed applications in windows firewall.

And I've tried changing port forwarding to TCP and BOTH in router settings.

  • When you are trying to connect from a machine outside of your network, are you providing the computer name to connect to in the format computername:3391? Also, is there any other device between your router and the Internet, such as an ADSL modem? – I say Reinstate Monica Nov 5 '14 at 2:39
  • I have a static ip address. So 1.1.1.1:3391. Using local ip when trying to collect locally. – clorz Nov 5 '14 at 9:15
  • Can you connect via RDP from outside your network if you have RDP configured to use the default 3389 port? – I say Reinstate Monica Nov 5 '14 at 16:12
  • 1
    I don't know if this has any relevance in your case. I had a problem like this on a non-standard port, and it turned out I had two firewalls running: one was from Kaspersky, which I disabled, but I found that Kaspersky hadn't disabled the standard Windows firewall, and it was this that was stopping external access to the port. Any chance you have another firewall on either machine? – AFH Nov 6 '14 at 11:45
0

Create an exception in your firewall for port 3391. You've already enabled the exception for Remote Desktop Protocol, but that allows the default port of 3389.

Make sure you're doing this on any firewall that's active on your machine. It's possible to have more than one product providing firewall services on a single machine.

| improve this answer | |
  • Why would it not work with the firewall completely disabled then? – clorz Nov 5 '14 at 15:36
  • @clorz Good point--I did not catch that it still fails to work with the firewall completely disabled. I'll ask more questions via comments on your question. – I say Reinstate Monica Nov 5 '14 at 16:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.