95

I have a formula in a cell which counts the values in 2 other cells. Normally, after entering in the values in these 2 other cells, the formula cell updates automatically when Enter is pressed or when the cells are clicked out of.

However, for some reason, the value calculated by the formula does not update automatically. I am having to click on the formula bar, then I have to click enter for the formula cell to do its thing.

Why is this happening?

migrated from stackoverflow.com Nov 5 '14 at 18:11

This question came from our site for professional and enthusiast programmers.

153

A likely cause is that Calculation is set to manual. To change this to automatic in the various versions of Excel:

  • 2003: Tools > Options > Calculation > Calculation > Automatic.

  • 2007: Office button > Excel options > Formulas > Workbook Calculation > Automatic.

  • 2010 and newer: File > Options > Formulas > Workbook Calculation > Automatic.

On Mac:

  • 2008: Excel Preferences > Calculation > Automatically

In some cases you may prefer to keep it set to manual, for example if there are many heavy calculations to perform. In such cases, you can simply press F9 when you want the calculations to update.

  • I have 2007 and somehow this option reverts back to manual. – 3bdalla Apr 25 '15 at 9:27
  • @3bdalla: Perhaps you have executed a macro that contains the line Application.Calculation = xlCalculationManual? – Jean-François Corbett Sep 29 '15 at 7:09
  • This seems to be workbook related, so it may need to be adjusted for each workbook. – Sablefoste Nov 23 '15 at 19:01
  • @Sablefoste: No, it isn't. At least not in Excel 2010 and earlier... Haven't tested 2013, but see no reason why this would change. – Jean-François Corbett Nov 23 '15 at 21:03
  • @RFB: Please don't edit other possible answers into this one. Just go ahead and post your own answer. I did it for you this time. – Jean-François Corbett Jul 4 '16 at 12:54
10

Confirm with Excel 2007: Office button > Excel options > Formulas > Workbook Calculation > Automatic.

Short key to refresh

Ctrl+F9

  • Thank you! We already had the calculation options set to automatic and didn't know why values weren't updating. F9 and Shift+F9 didn't help and left the values the same. Ctrl+F9 not only updated the values, but fixed the problem so it didn't happen again. – april4181 Dec 14 '15 at 20:52
6

I had a case of this just now on Excel 2010: a particular spreadsheet that would not auto-recalculate. I changed the setting as indicated above; but the auto-recalculate still did not work, and upon rechecking the "Calculation" option, found it had reset itself back to "Manual" all by itself. Three attempts later and it was still adamant it wanted to be "Manual" and nothing else.

So here is my solution to the problem:

Copy the contents of the spreadsheet to a new one, and deleted the old one (it wasn't a particularly important spreadsheet, thankfully), and everything was fine. I can only assume that somehow the file had become corrupted.

A good reason to keep backups.

  • 4
    If that workbook was an .XLSM or .XLSB it may have had a rogue Worksheet_Change or similar event macro that utilized Application.Calculation = xlCalculationManual and either errored out or simply did not reset it to xlCalculationAutomatic. – Jeeped Dec 22 '14 at 15:33
0

I also have had this problem with a very large spreadsheet that just stopped updating itself over the weekend, but having checked the above solutions, setting were already set to automatic, and sheet is too big to rebuild, so I was at a loss.

My solution was to find an old version of the same excel spreadsheet which was not having thses issuesbefore I archived it, which is of similar size and complexity to the current version.

I opened this spreadsheet, checked that this was still working and autoupdating with current installation of MS Excel and any new automatic office updates (which it did work with), and then just reopened the original spreadsheet. "Hey presto" it was working again.

0

I ran into an issue where some cells weren't calculating. I checked all the normal things, like cell type, auto calculation, etc...

What I found to be the problem was the formula and the fact that I surrounded numbers with quotes. That probably turned the cell into a text format cell, even though technically the cell was still a number and listed as one under the formats.

I stripped the quotes and the cells calculated as normal.

  • 1
    I suspect that your problem and its solution were different from the one in this question. The fact that there is a different accepted answer means that this problem is different from yours and that solution worked. Typically, the kind of error you describe (turning a value into the wrong type of argument for a formula), will produce an error message. In this question, there was no error message; formulas just required manual recalculation instead of doing it automatically. Your answer is really a somewhat random reference to a different problem you had. – fixer1234 Feb 24 '15 at 2:14
0

In my instance I was using a particular add-in called PI Datalink. Somehow PI's Calculate method was no longer running during the normal workbook recalculate. In Settings I had to change Automatic Update command to Full Calculate and then back again. Once the original setting had been restored, the add-in ran as normal.

0

Reposting this snippet that user RFB had (inappropriately) attempted to edit into my answer:

A possible cause is that the Office Prefs file is corrupted. In OSX this can be found in:

Library/Group containers/*.office/com.microsoft.officeprefs.plist. 

Delete this file and restart the OS. A new plist file will be created when Office is restarted. Formulas recalculated again perfectly.

Not the answer you're looking for? Browse other questions tagged or ask your own question.