11

I have see a lot of people asking this question and getting answers that supposedly worked. NOTHING I have found works for me.

I have a default Dell monitor that came with my Dell XPS 1700. It has Windows 7.

I recently got a great deal on a touch monitor for only $10. When I connect it to my computer, the touches go to the Dell monitor instead of the Planar touch monitor.

Here comes the problem:

When I go to control panel, tablet pc settings, setup, and try to complete it, I try to touch the touch monitor after hitting enter for the Dell monitor. NOTHING HAPPENS. The mouse clicks the main non touch monitor instead of the touch so i cant actually set the touch screen as the touch. I try clicking the correct monitor with my mouse. STILL nothing happens. I am really confused here and I really want to get this monitor to work.

Any answers are greatly appreciated.

  • 1
    My crystal ball is in the shop, can you please edit your question and tell us exactly what "NOTHING I have found works for me" covers? We don't know what you've found or tried already. – Ƭᴇcʜιᴇ007 Nov 5 '14 at 21:58
  • By nothing, I mean all of the usual solutions, most of them that I found are the one that I stated in the post. BTW thanks for the formatting. – Emanuel Elliott Nov 5 '14 at 23:43
  • See superuser.com/a/969683/8660 – TFD Dec 9 '15 at 10:25
6

Can you list what you've tried?

Windows 7

My first port of call would be display settings: Control Panel -> Settings -> Display -> Screen Resolution - set the the touchscreen monitor you wish to use as your Primary display.

Unfortunately in Windows 7 in a dual monitor setup, from experience, your touch screen will have to be the Primary display.

Windows 8; if you have both a touchscreen and non-touchscreen monitor connected to your PC, you might need to change settings for your cursor.

Swipe in from the right edge of the screen, tap Search (or if you're using a mouse, point to the upper-right corner of the screen, move the mouse pointer down, and then click Search), enter Tablet PC Settings, and then tap or click Tablet PC Settings.

Tap or click Setup. Administrator permission required You might be asked for an admin password or to confirm your choice.

If you’re given a choice, tap or click Touch Input, and follow the on-screen instructions.

Hope this helps :)

  • Well this answers my question as to if I can make this work right. Thanks for the response. Any ideas as to how the tablet pc settings button would work for me? Is it just a broken feature? – Emanuel Elliott Nov 6 '14 at 3:08
  • If this still is the accepted answer, look below for the correct answer for win 7. – Alex Oct 3 '16 at 8:58
14

Windows 7 is capable of this as long as the final step doesn't confuse you in what someone else already answered. I will try to explain the last step a little clearer.

  1. Press the Windows Key and type then click "Tablet PC Settings" listed under Control Panel.

  2. Click "Setup..."

  3. Keep pressing Enter until the text is written on the Touchscreen, then touch it!

Windows will then know what input (Touch) device is associated to which screen. :-)

  • Like I've said previously, even when I do this it would work fine if the monitor wasn't still sending touch clicks to the other monitor. Therefore it isn't possible to do it like this. I have long since come up with a solution, which is simply using the drivers and software suite provided on the manufacturer's website. Thanks for trying anyway though! – Emanuel Elliott Sep 8 '15 at 23:09
  • This works in Windows 7, 8, and 10 – TFD Dec 9 '15 at 10:24
  • I have a Dell external touch monitor that I'm trying to use with a non-touchscreen Windows7 laptop. Going through the Tablet PC Settings doesn't make it work, the touches are still registered for the primary (non-touch) display. – Sir Athos Jan 2 '16 at 20:55
  • This solution works on Windows 10 with my Wacom Cintiq 22HDT connected to a Surface Pro 4. After sleeping, Windows gets confused and the touch input goes to another screen (even though the pen input stays where it is). Consumer Reports was right to flag Microsoft Surface Pro as having quality problems... I almost always have to tweak my SP4 to get it to work properly after I've been away from it over night... – Fuhrmanator Aug 11 '17 at 21:01
5

Windows 10

  1. Go to Windows Settings (WinKey and search "Settings") and search for "calibrate the screen for pen or touch input"
  2. or: Run -> "control /name Microsoft.TabletPCSettings"
  3. Click the "Setup..." button
  4. Click Enter until you see the message on the screen you want
  • Requires Admin Privileges, in case anyone is trying on a work machine and doesn't have rights – chadiusvt Sep 5 '18 at 20:55
  • @chadiusvt thanks for mentioning that, actually I also need admin privileges, that's why I added #2 (so you can run command line as administrator, and enter the command) – ZivS Sep 6 '18 at 5:27
4

You are right there. I was frustrated with the same problem. Go to Control Panel/Tablet PC Settings. Click Setup. Hit enter to get to the screen you want. It will be the one with the message on it. Here is the problem, when you touch the screen, it will still select the main screen. So instead of touching the monitor you want, keep sliding you finger over the monitor to move the mouse. Keep doing it until the hand appears on the touchscreen monitor. Then tap the screen to complete the selection. The correct monitor will now be selected.

  • For some reason, this worked where trying it without sliding the cursor first didn't. Thanks! – Sir Athos Jan 2 '16 at 21:08
  • This exactly what helped me too. Forgot to read the small line about hitting Enter. – Benjamin Bojko Oct 24 '16 at 21:44
1

This is what worked for me:

  1. Go to Control Panel and search for "Touch".
  2. Click "Tablet PC Settings"
  3. Click "Setup..." to the right of "Configure your pen and touch displays"
  4. Choose "Touch Input..."
  5. Hit the "Enter" key until you see the instructions appear on your actual touch monitor. Touch the screen and it will say something like "Hit enter to move to the next step".

Actually found my answer here.

protected by Community Nov 16 '18 at 13:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.