5

Recently i've lost some fonts in windows. Though they show on the fonts list on control panel, they can't be used by google chrome. I believe this happened after I uninstalled some games.

If I delete the font, reboot, reinstall, reboot, they come back to life. But I can't uninstall "lucida console" (Windows complain it's a system font), which I believe is the font used by chrome.

So everything in chrome that have a tag (or even "View Page Source") show with Times instead.

Funny thing is I can use this font on other programs, but Chrome don't recognize it.

Here's a print of how it looks, with the extension "WhatFont" showing it's a "monospace" font.

enter image description here

And here's the same bit if I change the font to "Lucida Console, Courier" on the inspector, showing the Lucida Console is really not recognized:

enter image description here

Chrome version 38.0.2125.111 / Windows 7

So, how can I fix this?


Edit

I reboot and managed to delete Lucida Console. Rebooted, reinstalled. Rebooted again. Still no go. Myriad Pro is also not working. All other are ok.


Edit 2

Managed to delete the font right after a fresh reboot. Rebooted, installed the font. Rebooted. Still nothing.

  • Lucida Console Font Install Guides, possibly in Safe Mode? – JosefZ Nov 8 '14 at 21:58
  • Please edit your post. Add a screen capture of chrome://settings/fonts (just type it into the browser bar). Also, is Courier 10 Pitch (or similar) available in the drop down? – jww Nov 13 '14 at 4:17
1
+50

This seems like a bug in Chrome, so do not destroy your Windows fonts because of it.

The bug is reported on October 7 2014 in Issue 421305: Some fonts now broken in Chrome 38 stable :

Fonts that previously worked have suddenly stopped working after upgrading to Chrome 38 on Windows 8.1.

The bug is reported November 7 as :

This bug has a code fix and merge already.

With a bit of luck, this bug will be correctly fixed in the next version of Chrome.

Until then, one workaround mentioned in the bug report that worked for some (but not for others) is to disable DirectWrite in chrome://flags and relaunch chrome.
Please note that the flag's language is counter-intuitive, one should click "enable" in order to disable DirectWrite, not enable it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.