50

Today I've logged in thru remote session to my Windows 7 machine for the 1st time. After that I came back and on started working on site (physically on box), bud noticed immediately that my font is strange. I've reassured that ClearType settings are set. I don't know why it happen and how to restore it to be as it was. It's visible ex. on Google Chrome address bar

enter image description here

enter image description here

3
  • Is this happening for all apps or just Chrome? (i.e.: try windows explorer, IE etc.)
    – cdavid
    Nov 7 '14 at 1:44
  • 1
    Like the answers at the bottom say typing about:restart into the Chrome address bar and hitting enter worked for me. Jan 23 '18 at 15:56
  • Discord and Chrome fonts get demolished after disconnecting from RDP. Still holds true in Windows 10.
    – Brain2000
    Aug 15 '19 at 17:33
27

Make sure "Font smoothing" is checked in the "Experience" tab (MS RDC Client), if it doesn't help, please log off current user from the start menu and try again.

5
  • 2
    It's silly, but restarting my machine helped. Logging off not, yet it's OK answer for me. Nov 14 '14 at 9:22
  • i dont have an experience tab. maybe because im on Win7?
    – philx_x
    Aug 26 '15 at 9:18
  • 7
    This answer talks about smoothing the text while RDPing while the question was more about post RDPing.
    – Alexander
    Sep 19 '16 at 22:06
  • This, combined with Mladen B's chrome restart tip, works perfectly! Apr 12 '18 at 8:48
  • One also needs to adjust "Adjust ClearType Text" on remote machine. Please read the below article for full details. kb.firedaemon.com/support/solutions/articles/… Dec 28 '18 at 11:29
77

What helped me is to type the following in the Google Chrome's address bar :

about:restart

and press Enter. Chrome will restart and reopen all your tabs and your font smoothing should again work at this point.

7
  • 2
    Thank you! Been searching high & low for a way to get rid of the Roboto font after remote desktop session. Mar 13 '17 at 14:11
  • You have no idea how long I've been looking for this solution and yet it's so simple. Thank you! May 24 '17 at 12:28
  • 1
    I wish I could upvote this post every time I remote in to my computer and then need to look up this solution to fix my browser. This answer has helped me countless of times!
    – Tot Zam
    Sep 28 '17 at 14:36
  • 4
    This should be accepted answer!
    – Alex G
    Oct 9 '17 at 13:52
  • 3
    I'm a bit confused by the enthusiasm for this answer... Good if you only/mostly use Chrome I guses, but I use a lot of other programs, and they mostly continue looking terrible after an RDP session. Jun 14 '18 at 12:33
15

I resolved by changing the profile in the Performance configuration tab of Remote Desktop, from automatic quality detection to 10 LAN (the Font Smoothing checkbox got activated):

enter image description here

1
  • 5
    and after this about:restart from chrome tab, helps me to fix the issue. thankQ
    – sekhar
    Jul 31 '17 at 13:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.