10

How can I make VLC auto-select subtitles in an MKV when it opens?

I would like to select the 'English Subtitles - [English]' from this image:

subtitles

on auto-load (the reason for this is so I queue a list of media for a TV series to watch on a treadmill uninterrupted)

I was told to fiddle with these settings:

vlc settings

but have tried every combination from 0-3 without any luck.

Is this possible in VLC?

| |
  • I'm assuming this is on Windows (per the screenshot)? What version of VLC? – Raystafarian Nov 6 '14 at 12:44
  • Windows 7 - VLC 2.1.5 Rincewind – fostandy Nov 6 '14 at 23:24
10

For me, it worked with the following settings:

Subtitle track = 1

Subtitle Language = English

Subtitle track ID = 2

Hope you'll find this useful. (If it doesn't work, click on Tools, Media Information, Codec and look which stream type is Subtitle... That is your subtitle track ID! )

| |
  • This worked for subtitles, but not audio. I tried every combination of -1 to 5 in both fields, but nothing worked. :( The file contained tracks 0 to 4, of those 1 and 2 audio. – Fabian Röling Mar 10 at 21:05
6

The number you are inputting in Subtitle Track ID within the mkv container. Usually Track ID 0 will be the video stream and ID 1 will be the audio stream. Thus, starting from 2, you might have the embedded subtitle streams. If you have multiple audio tracks, however, those will be pushed back even further. Specifying the number directly like this is thus rarely a good way to do it, as it can vary from file to file unless you specifically encoded them all to be uniform.

I was unable to find out what exactly the "Subtitle track" setting does, but I would advise to leave it at -1, the default and revert the "Subtitle track ID" setting to -1 again as well.

If you want to automatically select English subtitles, then put "English" (not "en") in the "Subtitle language" field and it should automatically select the English language subtitles from your file if it is available. This likely does not work if the language is not properly tagged in the file, and I don't think it is possible to select the second English subtitles as you specified automatically.

| |
  • VLC reccomends using the 2–3 letter ISO codes, and when I use "en", it actually does pick the audio track that is set to language code "en". -- Using the full name "English" also work, but certainly not neccessary. – Liggliluff Nov 16 '19 at 2:01
1

To use English subtitles by default, try setting your "Subtitle track" to 1 and your "Subtitle track ID" to -1.

Set subtitle track to 1 and subtitle track id to -1

| |
1

I got mine working in the same situation.

AUDIO With the audio on my particular files, "disabled" = 0, first track = 1, second track = 2, so with Japanese as my second language option, for example, in the advanced Inputs/Codecs options I put:

Audio track ID: 2

As an alternative, I could just type in the name of preferred language, which works fine for audio.

--

SUBTITLES These are different for some reason; I guess it's as the user above said, and subtitle track IDs begin after the audio track IDs end. My particular subtitle options were "disabled", "(signs/songs) English" and "English subtitles". For English subs, this is what worked for me:

Subtitle track ID: 4

So just keep going up by one until you hit the right one. You can test your progress by checking which sub track you've landed on each time you raise the number using the manual selection feature: Right click video -> Subtitle -> Sub track -> (check which subtitle option is selected)

That will show you where your automatic selection is landing you in the subtitle list, so you can find the ID you're looking for by trial and error. If your subs are still showing as "Disabled" keep going (unless you've shot too far). If you've reached "(signs/songs) English" then you're on the right track and probably only need to raise by 1 more track ID.

--

For the record, I left both Audio track and Subtitle track unchanged, with values of -1.

| |
1

For those still looking for an answer to this question, the OP almost had it:

  1. Before going to your settings, hit ctrl + J to open the Codec Information Find the stream number of your desired default sub track. It's almost never 0 (video) or 1 (audio) but it varies by file
  2. Hit ctrl + P to open preferences
  3. select "All" settings in the bottom left (to get to the screen OP has)
  4. select "Input/Codecs"
  5. Change "Subtitle track ID" to the steam number found in step 1

A value of -1 will disable the override and will default back to the settings indicated in your simple settings. You probably want to do this when changing between shows, as it will rarely be consistent between different file-sets

Hopefully this will save someone the digging I had to do :)

| |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.