1

I have my custom stack folder located here...

C:\MEDIA\INTERNET\WAPP\

I have Apache located here...

C:\MEDIA\INTERNET\WAPP\Apache 2.4\

I have PostgreSQL located here...

C:\MEDIA\INTERNET\WAPP\PostgreSQL 9.3 x64\

...and I have phppgAdmin located here...

C:\MEDIA\INTERNET\WAPP\phppgAdmin 5.1\

How do I make phppgAdmin accessible via localhost at the url localhost/phppgadmin/?


So far I've gone in to C:\MEDIA\INTERNET\WAPP\Apache 2.4\conf\httpd.conf and added Include conf/extra/phppgadmin.conf so the file at C:\MEDIA\INTERNET\WAPP\Apache 2.4\conf\extra\phppgadmin.conf is seen by Apache. I've tried numerous iterations including my XAMPP stack's copy of phpmyAdmin code without success. Here is what I currently have in phppgadmin.conf...

Alias "/phppgadmin/" "C:/MEDIA/INTERNET/WAPP/phppgAdmin 5.1/"

<Directory "C:/MEDIA/INTERNET/WAPP/phppgAdmin 5.1/">
  Order Deny,Allow
  Allow from all
</Directory> 
0

Further research revealed that Apache 2.4 handles things a bit differently...

Alias "/phppgadmin/" "C:/MEDIA/INTERNET/WAPP/phppgAdmin 5.1/"

<Directory "C:/MEDIA/INTERNET/WAPP/phppgAdmin 5.1/">
Options Indexes FollowSymLinks MultiViews
Require local
</Directory>

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.