I'd like to be able to use WebGL-based sites like Shadertoy, WebGL Earth, etc, but those sites tell me that WebGL is disabled in my browser. How can I enable it?

up vote 167 down vote accepted

I've made this answer a community wiki post, so please update it if you notice any out-of-date or missing information.


Browser support for WebGL

Check caniuse.com/webgl to see whether your browser supports WebGL.


Enabling WebGL

If your browser supports WebGL, follow these instructions to enable it:

Chrome

First, enable hardware acceleration:

  • Go to chrome://settings
  • Click the + Show advanced settings button
  • In the System section, ensure the Use hardware acceleration when available checkbox is checked (you'll need to relaunch Chrome for any changes to take effect)

Then enable WebGL:

  • Go to chrome://flags
  • Ensure that Disable WebGL is not activated (you'll need to relaunch Chrome for any changes to take effect)
  • In newer versions, this option of Disable WebGL will not be available, you will instead have to search for WebGL 2.0 (or some different version) that looks like this:

    enter image description here

    Here you will have to change Default to Enabled in the drop down.

  • [Try this if above doesn't work] Enable - Override software rendering list

Then inspect the status of WebGL:

  • Go to chrome://gpu
  • Inspect the WebGL item in the Graphics Feature Status list. The status will be one of the following:
    • Hardware accelerated — WebGL is enabled and hardware-accelerated (running on the graphics card).
    • Software only, hardware acceleration unavailable — WebGL is enabled, but running in software. See here for more info: "For software rendering of WebGL, Chrome uses SwiftShader, a software GL rasterizer."
    • Unavailable — WebGL is not available in hardware or software.

If the status is not "Hardware accelerated", then the Problems Detected list (below the the Graphics Feature Status list) may explain why hardware acceleration is unavailable.

If your graphics card/drivers are blacklisted, you can override the blacklist. Warning: this is not recommended! (see blacklists note below). To override the blacklist:

  • Go to chrome://flags
  • Activate the Override software rendering list setting (you'll need to relaunch Chrome for any changes to take effect)

For more information, see: Chrome Help: WebGL and 3D graphics.

Firefox

First, enable WebGL:

  • Go to about:config
  • Search for webgl.disabled
  • Ensure that its value is false (any changes take effect immediately without relaunching Firefox)

Then inspect the status of WebGL:

  • Go to about:support
  • Inspect the WebGL Renderer row in the Graphics table:
    • If the status contains a graphics card manufacturer, model and driver (eg: "NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine"), then WebGL is enabled.
    • If the status is something like "Blocked for your graphics card because of unresolved driver issues" or "Blocked for your graphics driver version", then your graphics card/driver is blacklisted.

If your graphics card/drivers are blacklisted, you can override the blacklist. Warning: this is not recommended! (see blacklists note below). To override the blacklist:

  • Go to about:config
  • Search for webgl.force-enabled
  • Set it to true

(Like Chrome, Firefox has a Use hardware acceleration when available checkbox, in Preferences > Advanced > General > Browsing. However, unlike Chrome, Firefox does not require this checkbox to be checked for WebGL to work.)

Safari

  • Go to Safari's Preferences
  • Select the Advanced tab
  • Ensure that the Show Develop menu in menu bar checkbox is checked
  • In Safari's Develop menu, select Experimental Features sub-menu and ensure that WebGL 2.0 is checked

Notes

Upgrading graphics drivers

If your graphics drivers are too old to support WebGL, you may be able to upgrade them.

More information is available here:

Blacklists

Certain graphics cards and drivers are blacklisted by some browsers, because they are known to contain serious bugs or cause crashes. In very severe cases, these can even cause the entire computer to freeze! For example, this issue causes certain Mac computers to freeze and require restarting.

Many browsers have an option to override the blacklist (ie: attempt to use the blacklisted features, despite the risks). This is not recommended! You should only override the blacklist if you understand and accept the risks.

More information is available here:

  • 4
    For Firefox, on Ubuntu, I also had to reset gfx.crash-guard.status.glcontext (See from sourceforge.net/p/x3dom/mailman/message/34731616). I prefer to post as a comment before any edit to this community answer. – ThomasG77 Apr 12 '16 at 22:18
  • Well I have the most up-to-date version of Chrome (Version 57.0.2987.133 (64-bit)). But at the chrome://flags I changed "WebGL 2.0...Allow web applications to access WebGL 2.0" to enabled, there was one for "WebGL Draft Extensions" I left that alone. Yet still in chrome://gpu both versions are still unavailable, You mention video drivers, how would I know if mine supports it or not? I have an Intel NUC DCCP847DYE – Edward Apr 10 '17 at 22:51
  • Just tried going to webglearth.com on kubuntu 16.04. It worked fine without any changes in Firefox 54 and Vivaldi 1.10. ... Things do continue to get better. – Joe Jul 11 '17 at 6:05
  • Strange, in Firefox 56 (currently a nightly version) WebGL doesn't work even though it's all showing up OK as above. Hm. – mlissner Jul 26 '17 at 15:39
  • Seem that the webgl.* Firefox options are very poorly documented. What do they all mean? Here are some additional options to look at. – not2qubit Nov 5 '17 at 2:00

Very useful for Chrome - except that it might be best to clarify the Disable WebGL option - which is not obvious in Chrome.

The Disable WebGL option has to have been disabled (urgh - double negative), i.e. the link below must say 'Enable' - meaning that disabling webGL is off... May save someone a few minutes.

Best wishes Andy

protected by DavidPostill Dec 21 '15 at 21:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.