0

I have an excel spreadsheet that I am trying to print with a chart located in it. The chart is properly sized in the spreadsheet and looks fine when viewing it in the editor. When I go to print the sheet, the chart re-sizes and centers in the middle of the page as if it does not matter how I format it. How do I get my print preview to look like how I have it in the edit mode.

screen shots

13
  • 1
    There are several things that could be going on. If you click on the chart so it is selected at the time you print, it will print the chart. Make sure the chart is not selected when you print. Also, display the page break view and see what that shows. If the whole spreadsheet is larger than what will fit on a page, you could be getting the page that contains the chart, which could occupy a different location within that print page than what appears on the screen for the whole sheet. – fixer1234 Nov 6 '14 at 19:29
  • 1
    What have you researched or attempted to resolve this? Edit your question to include more details. As it is, your question is missing a lot of information we would need to be able to answer it. Printer settings are a major factor, are specific to each printer and act differently than the view settings. As fixer1234 states, it depends on how you are trying to print the chart. The page break preview will help you see if it is being automatically scaled to fit the page. – CharlieRB Nov 6 '14 at 19:35
  • This is an automatic excel creation and print that is launched by another program. The program loads a template, fills it with info, then prints. Every view besides the print preview looks correct. The print preview shows all the data underneath, but the chart instead of being displayed as it is sized, re-sizes to maximum and forces it into the center of the page. It is as if it is printing the chart and the data as two separate items overlapped on the same page. This issue is only on my computer, other computers are not having this problem. – Khamey Nov 6 '14 at 19:59
  • @fixer1234 I have posted the question with an image on stackoverflow as I do not have enough rep here to post images. stackoverflow.com/questions/26788546/… – Khamey Nov 6 '14 at 20:12
  • @CharlieRB I have posted the question with an image on stackoverflow as I do not have enough rep here to post images. stackoverflow.com/questions/26788546/… – Khamey Nov 6 '14 at 20:13
0

I've come across the same problem. Try to print 4 charts from Excel to one page and Excel looks good, even in page layout mode. Print preview, however, changes their size and page positions. The problem seems to stem from seemingly simple chart properties. Go to 'Format Chart Area' and examine Properties. My problem went away when I checked the 'Move but don't size with cells' option. In Size, Scale Height and Width are both set to 100%. Now, all 4 charts preview and print on one page (Landscape), correctly positioned and sized. I assume if the same charts are populated by macro or from 'feeding' sheets, they will print correctly if these settings are correct.

0

I was having this same problem in Office 365 (Excel version 1808).

I fixed it by going to Format Chart Area > Properties then changing the radio buttons for the move/size setting. It seems that changing this setting at all fixes the problem. In my case, I changed it to "Move and size with cells" then immediately right back to the setting it was on previously ("Move but don't size with cells").

0

I have had this happen. My hunch is that the problem resides in the printer settings (but i do not know where from there).

I have several printers linked to my computer (e.g. "Print to PDF") and when i switched to printing to one of them, the chart sized appropriately.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.