In a domain environment, we've got Office Pro Plus 2013 and it's KMS activated. The issue that I'm having is that there is an account error on the top right. The account displays my UPN correctly. I've checked the managed accounts and there are no Microsoft Live accounts. I've tried to repair and re-install with no luck. Does anybody have any thoughts on how to remove this error?

The error states:

Account Error:  Sorry, we can't get to your account right now.  To fix this, please sign in again.

When you go try to "Sign Out":

We can't remove Windows accounts.

If I try to "Switch Accounts", it states that I have the same email address with more than one account, allowing me to select Microsoft account or Work account. I try work account and try to authenticate and the message states:

We are unable to sign you in to Office.  Please access your documents through the browser.
  • What version of Windows.
    – Ramhound
    Nov 6 '14 at 19:27
  • The OS is Windows 7 Nov 6 '14 at 19:53
  • Feel free to update your question with that information.
    – Ramhound
    Nov 6 '14 at 20:06
  • Hi all, I encountered the same problem, what finally worked for me was aligning the language/region settings. The office version I downloaded (EN) didn't match with my local language settings. To adjust the local settings under Windows go to "Control Panel -> Clock, Language and Region -> Region" and make sure that on the Formats tab the format matches with the downloaded Office version. Additionally also check that the Windows Display Language in "-> Language" matches. It seems random, however for me it worked. Hope that helps!
    – QEconomist
    Mar 16 '17 at 11:26

Please check out the below link that has a good workaround. It talks about deleting / modifying the registry.


Changing the IdP value to 3 worked.

  • Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change.
    – DavidPostill
    Apr 4 '16 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.