2

A while ago I used Audacity to record the output from the computer speakers by using PulseAudio Volume Control to redirect the output to the "microphone". It worked fine. I then used Effect > Change Speed and saved the result. It all worked fine.

Since rebooting, I repeated these steps to capture some more audio output but without changing the speed. Nevertheless when I played back the result it was slower and lower in pitch. I then used Effect > Change Speed to increase the speed and that seems to have fixed it but at a cost in quality.

It is as if Audacity is applying previously used effects to new recordings, even in a different instance of the program. This seems bizarre, is that what's actually happening? How can I stop it?

  • Audacity's configuration is stored in ~/.audacity-data/audacity.cfg. You can rename this to restore the initial configuration, which should solve your problem. If you are interested, you can then compare the versions to see what has changed to explain what you have observed. – AFH Nov 6 '14 at 22:20
  • No difference, it still comes out slow and downpitched – spraff Nov 7 '14 at 20:17
  • Sorry, I can't explain that, unless you have something in your ~/.cache/. You could try it from another user (use root with care, if you don't want to create another). All that remains to try is complete removal, including configuration, then re-install. – AFH Nov 7 '14 at 20:59
1

I used Audacity with pulseaudio for recording a few times now. It was a little weird to see this working on my old notebook but my new notebook would always record slow. So, I thought it was a hardware problem and so I used my old notebook for these purposes.

Just now, I found out, that it has something to do with how many players are active (even when not running). When I close all except the one that I am recording from I do not face the slow recording problem. With another one open, I do - on both notebooks. So maybe if there are multiple channels pulseaudio messes something up - just a guess.

So, my solution: Close all unneeded players and hopefully it works!

Hope this is of help for you!

0

To add to pelican's answer, I experienced this exact same problem just now with trying to record system audio with Audacity in Linux. When I played back the recorded audio, it was noticeably slower and lower in pitch than the original source.

Firefox (Icecat) was the only sound source running; however, I had an external USB audio interface plugged in, as well as the JACK sound server running. After I closed JACK and unplugged the interface, the recording was fine. Not sure if the problem is with ALSA or Pulseaudio, but it seems that to be able to record system audio in Audacity effectively, all other sound source apps and external audio devices need to be removed.

-1

I just had the same problem using Windows 10. It occurred after I changed the Project Rate from 11025hz to 22050 hz. When I closed Audacity and reopened it, changing the speed from the very beginning of the recording, it resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.