I have created a Ubuntu Server 14.04 system that I would like to clone to several other machines with exactly the same hardware specifications. The system is an Intel NUC2820 with 30 GB SSD.

The current working installation contains three partitions:

/sda1 fat32 (efi boot)
/sda2 ext4
/sda3 swap

The system is set up using GPT and uses UEFI for boot.

With Tuxboot I created a CloneZilla USB and wrote the complete disk to an image that I would like to use to restore. However after restoring the image to a new machine I can't seem to find a way to make the system bootable again.

I tried using grub-install from the CloneZilla environment, but I get the following error:

warning : this GPT partition label contains no  BIOS boot Partition; embedding wont be possible
warning : Embedding id not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged..
error : will not proceed with blocklists

I guess this has something to do with grub not working in EFI mode. I have no idea if I can force grub to create an EFI partition. When I use efibootmgr i get the message:

efi variables are not supported on this system

I also tried to use the Ubuntu 14.04 Server installer, but re-installing Grub in rescue mode says:

executing 'grub-install' failed
This is a fatal error

When i execute grub-install from the shell I get the a message the Grub is successfully installed , although still can't find a boot disk upon start up.

Is there any way to get the image to be bootable again


After days of searching of course I find the answer myself an hour after I decided to post here.

Using a Ubuntu-based version of CloneZilla I got it to boot in UEFI-mode which was able to update the correct boot records.

  • So the ubuntu uefi clonezilla worked out of the box? Or you had to boot and repair the new image? – kross Nov 12 '15 at 21:55
  • Yes, it worked out of the box. I created an image from the Ubuntu install and wrote this to another machine. I did not had to update or fix any of the boot records. – Koen_R Nov 16 '15 at 8:09
  • I had the exact same experience with an UEFI Intel NUC. An older non-ubuntu Clonezilla woudn't restore the image properly. The same image restored (and booted) just fine when I used the newer Ubuntu specific Clonezilla. – bryan kennedy Nov 7 '16 at 22:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.