0

I installed Linux Mint on a relatively old computer setup that I have to use as a media centre on my TV. Since I am using a dedicated ATI graphics chip I need the drivers because the desktop extends past the sides of the screen.

I downloaded the Catalyst 13.1 legacy driver for 32 bit linux and ran the script. When it tries to install, it gives me an error. It says:

"One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver. Optionally, run the installer with --force option to install without the tools. Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended. See /usr/share/ati/fglrx-install.log for more details"

I checked out the .log file that it mentions and it says this:

"Check if system has the tools required for installation. fglrx installation requires that the system have kernel headers. /lib/modules/3.13.0-24-generic/build/include/linux/version.h cannot be found on this system. One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver. Optionally, run the installer with --force option to install without the tools. Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended."

I checked in the dir that it mentions and indeed, I could not find version.h

to try and fix the problem I did:

apt update

then rebooted. The error persisted.

I'm a Linux novice and would like some help to solve this issue. Thank you!

Graphics chip: ATI HD 4350 Driver Version: 13.1 legacy linux 32 bit Kernel: Linux version 3.13.0-24-generic (buildd@komainu) (gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1)

1

Short answer is: you can't. The legacy proprietary driver only supports X.Org server up to version 1.12 and linux up to version 3.4. Some patches were produced to port it up to kernel 3.8, but that doesn't solve the fact that current X.Org version is 1.16 (and that kernel 3.8 is still not enough for you).

You can either

  • Use the open source driver
  • Look for an older Linux Mint version with the X.Org and kernel version I mentioned (Linux Mint based on Ubuntu 12.04 should do the trick, however I do not have a direct Linux Mint experience and I cannot tell which version it is)
  • Look for another Linux distribution sticking with those older packages. Debian Wheezy, the current stable, has for sure fglrx-legacy-drivers in the backports repository.

FYI: to have the missing file, you should install linux-headers-(your-kernel-version). But as I told you, this won't help at all.

FYI2: apt update only downloads from the configured repositories the list of available packages in such repositories. It doesn't make any change to your system. apt upgrade and apt full-upgrade do (they will download and install updates for your installed packages), but again they won't help you in this specific problem. man apt is your friend.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.