0

I have two PCs, both with their own local accounts.

\\THINKPAD-T61P 
OS: Windows 7 Ultimate 32bit 
Username: Lappy

\\Matthew-PC
OS: Windows 7 Home Premium 64bit
Username: Matthew

Both of these users are on the same Homegroup, each PC can "see" each other from the Homegroup folder.

On Matthew-PC, I have a folder that was shared with the Homegroup (by right clicking on folder and clicking Share With > Homegroup (Read)).

On THINKPAD-T61P logged in as Lappy, I can see the folder I have shared on Matthew-PC, however when I try and open the folder to access the contents, it asks me for user credentials.

Why do I need to provide credentials of a user on the machine I'm trying to read files from?

I tested and indeed if I put in the user Matthew and the correct password it will give me access. This is pointless for me as I want to be able to share files with other people without them knowing my password.

On both machines, the Advanced sharing settings are the default for Windows 7, but most notably, the following (defaults) are used.

  • Turn on password protected sharing
  • Allow Windows to manage homegroup connections (recommended)

How do I share these folders without sharing passwords?

  • Turn off password protected sharing? – DavidPostill Nov 9 '14 at 1:42
  • Still asks for credentials. – Matthew Nov 9 '14 at 1:50
  • Is there not a box to check to "remember these credentials"? – Carl B Nov 9 '14 at 3:31
  • I don't want to use the account Matthew to read the shared files from the laptop. – Matthew Nov 9 '14 at 3:41
0

Turns out that the /Users folder was not shared on each machine. Re-creating the Homegroup fixed this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.