11

Roughly about a week ago I stopped being able to use keyboard navigation in Google Search (i.e. press tab and up/down arrows). I had no issues before, and I've changed nothing as far as I can tell.

The issue only occurs in Chrome (Firefox works fine). Google Search keyboard navigation works fine in Incognito as well, so I tried disabling all of my extensions to no avail. However, if I clear the browser cache the navigation works fine until I load up Gmail in Chrome again.

So it seems tied to the local Gmail cache data but I have no idea why or how to fix it.

  • +1 for investigating the issue before posting (So it seems tied to the local Gmail cache data but I have no idea why or how to fix it.) – Jon Nov 9 '14 at 6:24
  • I did some more debugging and it appears to specifically be cookies Gmail sets, as clearing all of the browser cookies fixes the issue. However clearing the individual cookies (as browseable in the settings) does nothing. – Desmond Weindorf Nov 20 '14 at 23:49
  • After adding a new account to Chrome I've found out the issue only exists with my primary account. – Desmond Weindorf Jan 20 '15 at 4:54
  • The keyboard navigation has now been disabled permanently :( See my new question here: superuser.com/questions/1234766/… – Bill Cheatham Jul 27 '17 at 9:52
15

It turns out that there's an option in the Google search settings that inadvertently disables keyboard navigation.

Make sure "Google Instant Predictions" is set to "Always show Instant results."

EDIT: I found the reason I kept accidently enabling this as well... if you hit tab and then enter (a natural instinct for me to go to the first link) it will select and activate the link for screen readers to disable the instant search - which causes this issue.

  • This isn't great because it limits to 10 results. – Steven Lu Jun 27 '15 at 2:53
  • OMG it was the screenreader!!! Well done for figuring this out. – Robino Jul 26 '17 at 14:17
1

Looks like this feature is available to some langs and some not. My search settings were in hebrew and was changed to english and now I have the search navigation!

https://www.google.com/preferences

0

This feature is no longer available out the box. This answer explains how to do it using Chrome extensions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.