I was having OSX Mavericks 10.9 in Vmware. It was working fine with VMware Tools installed and SVGA Drivers also. When Yosemite released, I updated it from App Store. I cam across many problems on this update.

  1. Graphics are very bad
  2. It is too much slow

What i tried:

  1. I updated latest VMware tools from VMware site
  2. Tried to install SVGA drivers again (could not find update for OSX Yosemite SVGA drivers here. These drivers were working well with Mavericks and made it blazing fast in vmware in my previous experience)
  3. Rpaired file and folder permissions both using Mac OS X's internal utility and using CCleaner application also.
  4. Cleaned all junk files (e.g. temp files) using CCleaner
  5. Tried to increase Virtual Graphics Memory size using configuration file of Virtual Machine and adding this line to it

    svga.vramSize = "sizeInBytes"

  6. Came across a link on internet link here. It suggested to run application called BeamOff (download link available on same site) and add it to startup to disable Beam Sync feature of Mac to improve graphics

By using option 6 mentioned above, when i launched BeamOff application, it suddenly made graphics smoother. So i added it to login item so that it may start with login of Mac. But to my disappointment, this improvement in performance (graphics + speed etc) was not too much great as i was having when using OS X Mavericks.

My Virtual machine is having:

  • RAM: 3GB
  • HDD Space: 150 GB

What is problem/ What is want:

1.Speedup OS X Yosemite performance (graphics + speed) as i was having before in Mavericks
2. I am having resolution of 1366*768 but When i am at login screen of Mavericks, i am not having this resolution (some black margins from left and right, looks like 1024*768). It changes to 1366*768 resolution after login process is complete and desktop is loaded. Please note it was working fine when i was having Mavericks (have 1366*768 resolution at login screen and desktop both).

up vote 2 down vote accepted

From my experience, Yosemite is using a lot more RAM than 3GB if you run it natively (no emulation). I imagine in virtualised mode it would take even more. I have 16GB installed on my system and Yosemite is using about 4-5 GB without any application running. Once I open other applications and run one or two virtual machines the available RAM can go down almost to under 1GB.

Virtual machines use a lot of RAM in Yosemite for creating file caches. For example, if I run a Windows XP or Mountain Lion VM in VMWare on a base Yosemite system and allocate about 4GB of RAM, VMWare will use more than that for caching files.

This is done for speed purposes, so that if you close the VM and want to open it later, it will take much less time to resume the VM if there is a file cache in RAM, than if there isn't one. You can test this by running sudo purge in the Terminal after you close a virtual machine, then re-opening it. You will notice that resuming the machine is much slower than if you didn't purge the RAM of the file cache.

Also, VMWare seems to not work well/recognise graphic cards in virtualised OS X. For example, I created two virtual machines, one with Windows XP and one with Mountain Lion. The Windows VM can play the same game, altough it's laggy even with 8GB allocated RAM, whereas the OS X VM can't even open the game, the application crashes at start. Which means the virtualised OS X doesn't even recognise there is an emulated graphics card.

  • 1
    I appreciate your answer. But i disagree. As you said that OS X VM takes lot memory. If this was the case then why it was working with excellent speed and graphics on same configuration of VM with mavericks (before I updated it to yosemite) with only 3gb RAM allocated to it and that too was not being fully utilized by VM. – Programmer Nov 10 '14 at 22:59
  • Because Yosemite uses more RAM than Mavericks. I gave an example with my setup, where I have Yosemite installed natively (not on VM) and it uses about 4-5GB from 16GB of installed RAM, without any other running applications. So, if you install Yosemite on a VM with only 3GB it will most likely not have enough RAM to run its system processes, let alone any extra launched applications. I think this happens because Yosemite caches a lot of things to be able to launch some applications faster or maybe because the new UI settings need more RAM to run without lag. – dolanator Nov 11 '14 at 14:28
  • 7
    This has nothing to do with RAM. I gave the VM 8GB of RAM and it made no difference (by comparison 10.9 was fast with 2GB of RAM). According to communities.vmware.com/message/2442827#2442827 this might be a problem with VMWare Tools. – Gili Nov 21 '14 at 23:39
  • 3
    @Programmer - If it does not solve the problem then you shouldn't accept the answer. When you accept an answer people who might know the answer won't bother to post the answer. – Ramhound Dec 18 '14 at 19:49
  • 3
    It's your choice but with an accepted answer your unlikely to get the real solution – Ramhound Dec 19 '14 at 21:02

In OS X veritcal sync is called beam sync.

Using BeamOff or Quartz Debug to toggle this setting may solve the UI lag problem.

  • 1
    It solves to some extent but can not see full performance. can you tell me how can i improve the login screen resolution. i have mentioned it problem above – Programmer Nov 18 '14 at 11:27
  • 2
    This fixed my Laggy UI, Thanks! – SimonGates Nov 29 '14 at 9:29
  • 1
    Great fix. The improvement in smoothness is instantaneous and significant after running this app. – Sébastien Dec 14 '14 at 11:47
  • 1
    I stumbled upon that same problem and found this answer to be the real deal. If you want to run BeamOff automatically at system startup instead of launching it at every run you can setup a LaunchAgent as explained in this post (full source code and installer included). – Darkseal Aug 7 '15 at 21:38
  • Why not just add BeamOff as a login item? – Foliovision Apr 15 '16 at 22:13

I ran into crippling slowness on a Mid-2011 iMac in Fusion 7 after upgrading to Yosemite. It wasn’t Fusion, but all hypervisors were hit by a bug found across the Mid-2011 lineup.

If that sounds like your Mac, you can fix it by restarting after running:

sudo nvram boot-args=debug=0x10

I’m not sure why it works, but it does.

Here’s a Parallels KB on it. Here’s a VMware community post claiming Apple is aware of the bug. As JBingham writes on the VMware boards, the above command will overwrite any existing boot-args, so run a check with:

sudo nvram -p | grep boot-args

I believe that a recent advent in Mac OS X development may be to blame for the issue delineated:

https://derflounder.wordpress.com/2014/12/13/improving-yosemite-vm-performance-in-vmware-fusion/

According to multiple sources (including the one listed above), even having the VMware Tools installed won't help much - it's the way in which Mac OS X handles graphics and GUI.

With the advent of OS X Yosemite (and newer versions), a new system for Screen Redrawing and Window Management was introduced. It's called Beam Syncrhronization. As a result, Mac OS X now uses a lot more physical memory, but runs well on physical hardware (especially MacBooks, obviously).

But, this change hurts virtual machine users - the new system slows down performance on virtual hardware. It's because the new Beam Syncrhronization system doesn't appear to have been designed with virtual machine users in mind. As you noted, changing the amount of RAM won't change a thing. I even tried increasing the number of CPU cores that VMware Player could use - that was practically useless.

As a result, it is suggested that you disable Beam Syncrhronization by going into Apple's native Quartz Debug developer tool, and selecting "Disable" under the "Beam Sync" menu. As an added pain, unfortunately, you'll have to repeat the process everytime you login. I am sorry to be the bearer of bad tech news.

Fortunately, BeamOff - an application desinged by JasF on GitHub, has been created to fix this issue. Its sole purpose is to disable Beam Sync, which should vastly improve performance, in theory. But, if you don't like the given solution, I'm guessing that a shell script/AppleScript could be designed for the given task as well. But, I haven't AppleScripted in years (since the release of Leopard/SnowLeopard), so I can't help in that endeavour.

Edit - It should be mentioned that the fix delineated above is actually a part of Apple XCode Tools, and doesn't come with Mac OS X. Therefore, you'll have to download it from Apple's online repo. The tool you would need in this case is one from a group of Graphics (optimization) tools.

Good Luck.

Try uninstalling the SVGA driver. It's not working for Yosemite (yet).

  • 4
    This is a "destructive" type of recommendation. I don't know whether this is good or bad advice, but if you make this type of recommendation, especially as a new user, it has the appearance of fly-by vandalism. If this is a serious recommendation, please expand your answer. Cite a basis for the claim that it isn't working yet. Describe what the other consequences might be. Explain how to uninstall and how to undo that action if it doesn't work. What driver should be used, where can that be obtained, and how would that be installed? – fixer1234 Dec 19 '14 at 0:52

protected by Community Apr 8 '15 at 17:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.