9

This question already has an answer here:

Starting with windows 8 I have many many many hardware issues (that are not present in Windows 7). One of these issues is the fact that an initiated restart does not work. It shuts down, the bios shows up, loads, then the windows boot loader begins loading and suddenly the progress ring halts and nothing happens anymore (I have tested it for several hours). While this is not really a problem usually (If a service attempts to initiate a restart I just pull the power after saving everything) with windows 10 it became a problem. A while ago obviously a new build was released and it tried to install said build. This is done using an initiated restart. The restart happens, it hangs in the boot loader and when I reset the machine I get the usual "Your windows has been reverted to an earlier version" message. So far so good. The problem is that since then every day this happens. It randomly asks me if I want to apply the update now, I obviously dont want it to, and set it to remind me again in 8 hours. I dont know what insane person had the idea that a forced shutdown that kills every living thing on your computer was the appropriate action for something as utterly unimportant as an update but sadly after these 8 hours it does exactly that.

After loosing a several gb download and a very long compilation has been corrupted I'm now ready to do everything to stop this madness. I first tried it the nice way and checked the update settings. Windows responds witht he following: enter image description here

A note here: I am the system administrator, this is a home computer and I am on the only account there is. How do I get rid of this non-sense?

Next I tried to forcefully kill the entire update service. It seems it worked for regular updates, but the preview build update is something that is not covered by that. When I go to the settings for new build installations all I am able to change is the time new builds should be installed (if available). Is there a way to completely disable that?

So to summarize: Is there a way to prevent windows from performing any action if there are updates? Or disable updates completely? Making everything manual? In the end the updates have destroyed more on my computer than they have prevented.

marked as duplicate by Ƭᴇcʜιᴇ007, karel, fixer1234, DavidPostill, music2myear Mar 9 '17 at 19:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Don't use Windows 10 for your important data, as it is only a development build – tommyip Nov 9 '14 at 23:00
  • I dont, thats why even more im not interested in updates that dont work, theres nothing that needs to be protected. – Cromon Nov 9 '14 at 23:57
9

This is what I do when it's nearly at the end of the month (I'm on a data cap):

With Group Policy

Press 'WIN KEY + R' and type in gpedit.msc to start the program, see this link if your version lacks the utility.

The Configure Automatic Updates setting can be found at Computer Configuration -> Administrative Templates -> Windows Components -> Windows Update > Configure Automatic Updates

Change the Group Policy setting to Allow local admin to choose setting:

enter image description here

enter image description here

The configuration Never check for updates is missing. Apparently if you choose Check for updates but let me choose whether to download and install them, Windows will get on your nerves with update messages during your tests, though I haven't experienced them myself.

Now, if you want to COMPLETELY disable Windows Update, then you can do it using the Registry. I don't recommend doing this since the point of using Win10 is to provide feedback to Microsoft, and if you don't have the latest updates you'll just end up reporting fixed bugs, not to mention the security issues too.

Go to HKEY_LOCAL_MACHINE SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\AUOptions

If you set AUOptions to “1”, Windows 10 will never check for updates. Note that this will only work if you keep the default configuration of the above-mentioned Group Policy setting.

enter image description here

There's also another method to do it with Powershell which is also in the site I linked.

Source: This site.

  • Thank you, it worked for to disable automatic updates, I hope it also does for automatic build installs! – Cromon Nov 9 '14 at 23:56
  • After changing the group policy how do you get the 'Windows Update' through the control panel, I can not locate it through search and otherwise. – Daniel Sokolowski Sep 29 '16 at 13:46
  • I have the same question as @DanielSokolowski – langlauf.io Jun 30 '17 at 8:27
6

I would like to add one more way to disable Windows Updates.

Open Local Services, search for Windows Update in list, open properties and choose Disabled.

Windows Update service

Just keep in mind that this will also prevent manual updates installation.


Another way to disable Windows Updates (I haven't tested this roughly, so it still might start update):

Open Local Services, search for Windows Update in list, open properties and choose Manual. Now open Task Scheduler and then go in Task Scheduler Library > Microsoft > Windows > WindowsUpdate, then right click on Automatic App Update and click Disable (also disable Scheduled Start and sih, but don't disable sihboot).

Task Scheduler

This won't run at startup, but there is no guarantee that Windows Update won't be started by some other process.

  • Instead of Disabled, could you set it to Manual and also Stop the service? – Dan Henderson Sep 1 '15 at 18:25
  • Yes, but you will also need to disable it in Task Scheduler. I have updated answer to answer your question (it would be too large for comment). – DRAX Sep 2 '15 at 7:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.