0

That and The program can't start because d3d9.dll is missing from your computer

I installed Visual Studio 2013 last night and today trying to load Skype or any game fails with this message.

  • I've run dxdiag and no problems are being reported
  • I've download the DirectX web installer but when I run it - it refuses to run installation because "DirectX has determined that a newer or equivalent version of DirectX has been installed already. No installation is necessary"
  • I've tried Windows Restore to several snapshots before Visual Studio got installed, but all fail

Searching for d3dx9.dll I find 52 occurences dotted around Steam, System32 and SysWOW64

Can anyone help? I'd really not reinstall my whole system for one file :(

0

If the latest DirectX installation doesn't help then try installing the 'DirectX' from the software package of Visual Studio 2013 or from the gaming application. Many times, the 'DirectX' comes with any application package will suit perfectly rather than the latest available version. Uninstall the existing version and install the version available in the package and check the results.

Also, update your video card drivers to the latest version and check the outcome.

Hope this helps.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.