7

I'm trying to rename the volume name of a mounted ISO image using the command:

diskutil rename /dev/disk15  TEST_DISK_2014_RENAMED

I get the error:

TEST_DISK_2014_RENAMED does not appear to be a valid volume name for its file system

I tried running this with sudo with the same results.

$ diskutil info /dev/disk15:

Device Identifier:        disk15
Device Node:              /dev/disk15
Part of Whole:            disk15
Device / Media Name:      Apple read/write Media

Volume Name:              TEST_DISK_2014
Escaped with Unicode:     TEST_DISK_2014

Mounted:                  Yes
Mount Point:              /Volumes/TEST_DISK_2014
Escaped with Unicode:     /Volumes/TEST_DISK_2014

File System Personality:  UDF
Type (Bundle):            udf
Name (User Visible):      Universal Disk Format (UDF)

Content (IOContent):      None
OS Can Be Installed:      No
Media Type:               Generic
Protocol:                 Disk Image
SMART Status:             Not Supported

Total Size:               84.0 MB (83996672 Bytes) (exactly 164056 512-Byte-Blocks)
Volume Free Space:        0 B (0 Bytes) (exactly 0 512-Byte-Blocks)
Device Block Size:        512 Bytes

Read-Only Media:          No
Read-Only Volume:         Yes
Ejectable:                Yes

Whole:                    Yes
Internal:                 No
OS 9 Drivers:             No
Low Level Format:         Not supported

$ bash --version:

GNU bash, version 4.3.27(1)-release (x86_64-apple-darwin12.5.0)

Variations:

diskutil rename TEST_DISK_2014  TEST_DISK_2014_RENAMED
diskutil rename /Volumes/TEST_DISK_2014  TEST_DISK_2014_RENAMED
diskutil rename /Volumes/TEST_DISK_2014  /Volumes/TEST_DISK_2014_RENAMED
/Volumes/diskutil rename TEST_DISK_2014  "TEST_DISK_2014_RENAMED"
diskutil rename TEST_DISK_2014  'TEST_DISK_2014_RENAMED'
diskutil rename 'TEST_DISK_2014'  'TEST_DISK_2014_RENAMED'
diskutil rename "TEST_DISK_2014"  "TEST_DISK_2014_RENAMED"

Nothing works.

So what's the story? What is the proper syntax? I could find no other examples.

4
  • Check out this forum post: serverfault.com/questions/361474/… – vembutech Nov 11 '14 at 22:11
  • That's really kludgy. I'd much rather learn do it with diskutil or some other OS X tool. – hmj6jmh Nov 11 '14 at 22:58
  • I tried that script but it didn't change the volume name. It wrote the new name in the specified location but I don't know what it did to the data. In a hex editor, the volume name occurs multiple times in different locations. – hmj6jmh Nov 12 '14 at 4:48
  • In any case, it's not a good idea to mess with the data like that. I think the problem is the ISO format is read-only. Is there a way to make it read-write without making a copy? – hmj6jmh Nov 12 '14 at 5:08
11

I found the solution on this blog post: http://rexstjohn.com/fixing-does-not-appear-to-be-a-valid-volume-name-for-its-file-system/

If you are trying to use the terminal in OS X to reformat a volume and you are getting “error: does not appear to be a valid volume name for its file system” – You need to capitalize the name of every letter in the name you are trying to specify like this:

diskutil partitionDisk /dev/disk2 1 MBRFormat "MS-DOS FAT32" EDISON 805.30M`
1
  • Note that the name is in all CAPS and also has no " ". – lars_bx Jan 27 '16 at 7:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.