1

Of the 6 back USB ports (4 USB 3.0 in blue, and 2 USB 2.0 in black), 2 of the 3.0 ports are not functional. (The 2 other 3.0 ports are working after installing the ASMedia USB3.0 drivers) Plugging something into these nonfunctional ports will give power to the device, but the OS doesn't respond.

The Windows Device Manager lists the device as Universal Serial Bus (USB) Controller in the unknown devices category. Attempting Update driver software automatically does nothing useful (the usual no drivers found error), but searching inside the chipset driver .zip from the ASUS website gives the following error:

Windows encountered a problem installing the driver software for your device.
Windows found driver software for your device but encountered an error while
attempting to install it.

AMD USB 3.0 Host Controller

The system cannot find the file specified.

Based on the technical specs of the motherboard, the nonfunctional are from the following chipset:

AMD A75 FCH (Hudson D3) chipset : 
4 x USB 3.0 port(s) (2 at back panel, blue, 2 at mid-board)

Searches for this chipset's driver turn up no real results other than ASUS.com product pages.

Why do these ports not work, and what steps do I take to get them working?

Version information and models:

  • Windows: 7 SP1
  • Motherboard: F1A75-M PRO R2.0
  • Downloaded Chipset driver: Version 5.12.0.13
  • Downloaded USB 3.0 driver: Version 1.16.2.0
3
  • Did these ports ever work?
    – Ramhound
    Nov 12 '14 at 3:05
  • On an earlier OS install (Windows 8) they did work. Nov 12 '14 at 3:07
  • Is this an OEM machine?
    – Ramhound
    Nov 12 '14 at 11:44
1

I would suggest you try the following:

Make sure both the USB driver "Downloaded USB 3.0 driver: Version 1.16.2.0" and chipset driver "Downloaded Chipset driver: Version 5.12.0.13" you mentioned in your question are installed on your system.

Then, from device manager, select the unknown device AMD USB 3.0 Host Controller right click and chose remove then reboot your system.

When windows starts up after reboot it should try to install driver for the newly found hardware, if it asks for a driver placement choose "have disk" (or whatever it's called) and point the installer to your AMD chipset driver (somewhere in the folder you point to there should be an *.inf file)

See if that helps..

2
  • Rebooting in between uninstall of the MS driver was the trick here. Thanks. Nov 16 '14 at 22:53
  • Glad it worked!
    – Kristian
    Nov 17 '14 at 14:42
0

normally when you unzip the drivers they arent cab files

you will get a folder with a load of files in there--some may be cab

but there will be an exe file--usually called asus setup

just double click that

no need for manual browsing to the drivers

i usually make a folder on the desktop

call it drivers or whatever you want--download all the drivers into it.

From Tom's Hardware: http://www.tomshardware.com/forum/69734-63-asus-motherboard-drivers

0

Uninstall all the Windows Drivers that installed this week, worked for me on my Asus z77 board. Trust me, this is not a driver update fix, MSFT has done it again! XD

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.