0

I have a chromebook and two PCs running ubuntu.

I can SSH between the ubuntus using their host names without any problems. But when I try to ssh using the secure shell extension on the chromebook, using the same host names (with or without ".local" suffix), connection is refused. If I connect using the IP address, however, it works.

Why is this happening?

1
  • What is the exact error message with which the connection is refused? If this is very terse, you should start the sshd server on one of the Ubuntu machines by hand (sudo service ssh stop; sudo /usr/sbin/sshd -d), then try to connect from the chromebook. This produces lots of messages on the Ubuntu pc, hopefully some will help diagnosing the problem. – MariusMatutiae Nov 12 '14 at 10:42
0

Well, if you are behind a NAT (you use private IPs on hosts) and you have a local DNS server, maybe the Chromebook is not configured to use the local DNS to look up the host names of the ubuntu machines. Because it maybe uses a DNS that is outside the LAN, thus it cannot resolve the hostnames you pass to the ssh command.

From my experience, ubuntu machines know to look to a local DNS first. Configure the Chromebook to interogate the local DNS first.

1
  • I'm behind a router, so what you're saying makes sense. But how do you configure a chromebook to interrogate the DNS without developer mode enabled? – Uri Nov 12 '14 at 10:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.