12

As documented here, Google Chrome has an automatic spell-check built in, and it is possible to disable it for certain fields temporarily.

Can it be disabled for all sites?

8

On OS X the checkbox is now under Edit -> Spelling and Grammar. Note that the browser must be focused on a text box for the menu entry to be enabled.

On my system the checkbox appeared as set only after I restarted Chrome. The red lines disappeared immediately as I unchecked it.

disable spellchecking

  • 2
    Wonderful, thank you - the trick of focusing on the text box to get the option to enable is key. – kmoe Feb 14 '16 at 19:33
1

Go to Chrome Settings (Enter chrome://settings/ in address bar)

Click on Advance Settings and then click on Language and Input settings and then untick the Enable spell checking check box.

  • 3
    I can't see that option. I'm on Chrome 38 on OSX. Perhaps it's different on Windows? – kmoe Nov 12 '14 at 14:14
  • 3
    -1 The question is for OSX. This answer doesn't apply on macs. – martin jakubik Dec 16 '15 at 9:24
1

Enter chrome://settings/languages in the address bar

A dialogue box will open listing the installed languages.

At the bottom is a tickbox labelled Enable Spell Checking.

Untick the box. This should disable spell checking everywhere.

Screenshot of dialogue

  • 5
    What if I don't have that checkbox??? – Dmitry Sep 4 '15 at 17:19
  • 2
    Damn! The tickbox disappeared in version 47. – Jairo Bochi Dec 5 '15 at 20:14
  • 1
    -1 same reason: this answer does not apply to OSX. – martin jakubik Dec 16 '15 at 9:25

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.